Question Fans run, lights turn on, cpu, ram heats up but no display

Aug 15, 2019
7
0
10
0
I turned off my 3yr old pc last night. A normal shut down. But this morning all of a sudden it won't turn on. Cpu fan, motherboard fans run, cpu, ram gets hot but that's it. No display. I don't have a speaker in motherboard so no beep code. Tried changing my 8gb ddr3 ram with a 2gb ddr3 ram. Didn't work. Replaced hard drive, didn't work. Removed every peripherals, cleared cmos but to no avail.
Same issue occurred couple weeks ago but i just cleaned the ram's connector part with eraser and it went ok. But now that too won't work. Normally the hard drive r/w light would stay turned on until windows is loaded completely, but now it doesn't lit up at all.
I know it's not the gpu. Neither the monitor. Probably not the ram either.
So is it the psu? Mb? Or the cpu? And how to check if I don't have anymore spare parts or checking tools?
 
Last edited:

Lutfij

Titan
Moderator
List your specs like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS:

How old is the PSU? It could be the PSU not being able to power the entire system but it's best you list your specs first.
 
Aug 15, 2019
7
0
10
0
List your specs
Here are the specs-
CPU- AMD FX-6300
MB- Gigabyte ga-78lmt usb 3
Ram- HyperX 8 GB ddr3 1866mhz
HDD- Toshiba 1TB
GPU- Nvidia gt 1030
PSU- Frontech 500w

Psu is 6 months old. I had to replace the one that came with the case. I know that it's not a very good psu but it was working enough as I'm not a heavy user.
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts