Question Fans spin fast two cycles, then beep, stuck at BIOS splash

Jan 11, 2020
1
0
10
0
So recently, my PC has had the fans spin up twice and then the POST beep, and then stuck at the BIOS splash screen with the BOOT_LED solid red.

It happened a few days ago too but I was able to hit the reset button and it would continue to Windows fine.

PC Specs:
  • OS: Windows 10
  • Bios: American Megatrends
  • Mobo: Asus Z97-A LGA 1150 ATX R 2014
  • Tower Size: ATX
  • CPU: Intel Core i5 4460 (Haswell), 2014
    • Copper heat sink w/fan installed
  • GPU: AMD Radeon R9 380
  • Memory: DDR3, 24GB, Blue Ripjaws 9-9-9-24, slots 4gb-8gb-4gb-8gb
  • HDD: WDC WD20EZRX-00D8PB080 (Green 2TB)
  • SSD: Samsung SSD 860 EVO 500GB
  • Power Supply: CORSAIR RMx Series RM550X 550W 80 PLUS GOLD Haswell Ready Full Modular ATX12V & EPS12V SLI and Crossfire Ready Power Supply
  • Optical (CD/DVD) drive...
Recently I had migrated to the SSD, as well as the two 8GB Ripjaws, back in August. One issue might be the PSU now is struggling to power everything but it should have enough output...

Troubleshooting so far:
  • Clear CMOS, with and without battery.
  • Unplug GPU, use integrated graphics.
  • Unplug new SSD, although if it was a boot order issue I assume it would've at least gone to BIOS settings.
EDIT: Did a quick power calculator, came in around 507W with the typical gaming I do. I'd assume it wouldn't turn on or it would shut off if the PSU was the issue though...I think we can narrow it down to the MOBO or CPU?

EDIT: I've reseated the RAM, also tried resetting CMOS battery for longer (15 min). Still not getting past BIOS splash. Can confirm all the LEDs for display, CPU, and Mem still blink and then solid red boot led (which I think is normal from looking at my tower in the past). I'd hate to think something is fried on the MOBO but that seems to be the only thing not cooperating now...
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS