[SOLVED] Fans wont spin

Nikko G

Reputable
Aug 25, 2015
131
2
4,685
0
Hi guys, recently bought a Rosewill Cullinan V500 and the system fans will not spin. My radiator fans are working but the 3 intakes and 1 exhaust will not spin. They have power going through them because the LEDs are working but they will not spin.
 

Darkbreeze

Titan
Moderator
Looks like there is a three speed, probably low, high and off, fan switch on the front of the case. It looks like a sliding switch all the way to the right. Have you tried moving that to one of the other positions?
 

Darkbreeze

Titan
Moderator
So where are the fans connected? Did you connect anything to them? If they came preinstalled then they are likely connected to a hub which is located on the backside of the motherboard tray and you will likely need to connect THAT to one of your motherboard fan headers in order for them to work. The hub is likely already connected to power for the lighting through the front panel connections OR you connected the hub to power somehow. I can look through that cases manual, and find out, because it likely says exactly how they are to be connected, or you could as well do that yourself. Either way.
 

Nikko G

Reputable
Aug 25, 2015
131
2
4,685
0
So where are the fans connected? Did you connect anything to them? If they came preinstalled then they are likely connected to a hub which is located on the backside of the motherboard tray and you will likely need to connect THAT to one of your motherboard fan headers in order for them to work. The hub is likely already connected to power for the lighting through the front panel connections OR you connected the hub to power somehow. I can look through that cases manual, and find out, because it likely says exactly how they are to be connected, or you could as well do that yourself. Either way.
Manual doesnt say anything about how the hub in the back is connected. Going to find any wires not plugged in and see.
 

Nikko G

Reputable
Aug 25, 2015
131
2
4,685
0
So where are the fans connected? Did you connect anything to them? If they came preinstalled then they are likely connected to a hub which is located on the backside of the motherboard tray and you will likely need to connect THAT to one of your motherboard fan headers in order for them to work. The hub is likely already connected to power for the lighting through the front panel connections OR you connected the hub to power somehow. I can look through that cases manual, and find out, because it likely says exactly how they are to be connected, or you could as well do that yourself. Either way.
So it looks like the hub has 6 wires coming from it. 4 are from the 4 fans, one goes towards the front panel and then theres one that looks like a molex connector. I have the molex connector plugged into the psu.
 

Nikko G

Reputable
Aug 25, 2015
131
2
4,685
0
So where are the fans connected? Did you connect anything to them? If they came preinstalled then they are likely connected to a hub which is located on the backside of the motherboard tray and you will likely need to connect THAT to one of your motherboard fan headers in order for them to work. The hub is likely already connected to power for the lighting through the front panel connections OR you connected the hub to power somehow. I can look through that cases manual, and find out, because it likely says exactly how they are to be connected, or you could as well do that yourself. Either way.
Those are the only wires I see and everything is plugged in but the fans are still not spinning not sure what to do anymore
 

Nikko G

Reputable
Aug 25, 2015
131
2
4,685
0
Those are the only wires I see and everything is plugged in but the fans are still not spinning not sure what to do anymore
I disconnected the molex connectors and the fan leds turned off. Idk if its a bios setting or of the molex controls only led or fan power as well
 

Darkbreeze

Titan
Moderator
Looks like there is a three speed, probably low, high and off, fan switch on the front of the case. It looks like a sliding switch all the way to the right. Have you tried moving that to one of the other positions?
 

Nikko G

Reputable
Aug 25, 2015
131
2
4,685
0
Looks like there is a three speed, probably low, high and off, fan switch on the front of the case. It looks like a sliding switch all the way to the right. Have you tried moving that to one of the other positions?
Yeah just realized theres a built-in fan controller lol, feel like an idiot. I started freaking out when the mobo was not reading the 4 fans lol. Thanks.
 

ASK THE COMMUNITY

TRENDING THREADS