Far Cry 2, Crashing and Damaging Nvidia drivers

Status
Not open for further replies.

Sarkamen

Distinguished
Sep 20, 2007
16
0
18,510
0
Hi all,
I downloaded and installed far cry 2 on Friday off of Steam. I really was starting to enjoy the game when about 30 minutes into the game it froze then the screen flashed blue then it went back to the frozen game and I couldn't do anything but ctrl-alt-delete and end the process via keyboard control. Windows Vista gave me a "NVLDDMKM" failed and has recovered. If I try to play the game it will immediately give me issues upon loading up the main menu. I then would have to reinstall my nvidia driver to get it to play again for a short period of time. I have tried the new 180.42 and 43 beta drivers as well as the older 178.24. I have tried both Direct X 10 and 9, I have fiddled around with HDR and other video setting to see if it was a specific cause, but to no avail. I have been searching for the solution and tried playing in windowed mode as well as switching from windows aero to windows vista classic desktop mode as suggested by some on other forums. There was a time when Dark messiah of Might and magic came out on steam and I was having the same issues, but then it must have been addressed in a patch because I no longer have the issues with any games I play but this one. I have heard that this was an issue with Nvidia but was hoping someone might be able to help anyway...Thanks


My specs are...

ASUS P5K-E/WIFI-AP LGA 775 Intel P35 ATX Intel Motherboard
Intel Core 2 Duo E8400 Wolfdale 3.0GHz 6MB L2 Cache LGA 775 65W Dual-Core Processor
EVGA 320-P2-N815-AR GeForce 8800GTS 320MB 320-bit GDDR3 PCI Express x16
G.SKILL 2GB (2 x 1GB) 240-Pin DDR2 SDRAM DDR2 800 (PC2 6400)

Thanks in advance
 

brendano257

Distinguished
Apr 18, 2008
899
0
18,990
1
I would keep trying other things, sounds like it's Steam, I was considering getting it on Steam, but decided against it and pre-ordered it from GameStop. Try re-installing the game if possible and check the registry to make sure it's gone. I havn't had any problems like that yet, although I didn't get it on Steam, and don't have Vista.
 

jimmysmitty

Champion
Moderator
Its not Steam. Do a complete uninstall of your drivers. I mean complete. Uninstall, restart into Safe Mode and run a program called Driver Cleaner to get rid of the extra traces. Restart and install the latest ones. Then try again.
 

DannyBoy27

Distinguished
Sep 4, 2007
93
0
18,630
0
I must admit - my PC has been stable for a while now and is a total beast but i too got a BSOD yesterday in Vista 64 Ulti. My first blue screen is ages.

So i was wondering if it was just memory leaks in the first version of FC2 or something similar.
 

Sarkamen

Distinguished
Sep 20, 2007
16
0
18,510
0
Well I tried cleaning out the drivers and installing them fresh and I am still crashing. Hopefully they will patch the game or something unless anyone else has some ideas. Thanks Anyway.
 

DannyBoy27

Distinguished
Sep 4, 2007
93
0
18,630
0
I got the latest nvidia beta drivers last night, uninstalled my current nvidia drivers, rebooted into safe mode, used Driver Cleaner on Nvidia, rebooted and installed the new beta drivers. Played for about 5 hours with no lag, bugs, stalls, glitches or BSODs of any kind. The game ran much better than before.

So, i guess they were actually optimised for FC2 :)

Oh, and by the way - i swapped down to DX9 late last night and apart from the obvious fps improvement, i didnt notice any issues - not to mention the more important fact that i also didnt notice any difference/decrease in graphics quality...

DX10 sucks balls hard. What a load of BS for sure!
 

Sarkamen

Distinguished
Sep 20, 2007
16
0
18,510
0
Yeah, I noticed the graphics thing as well. We must have had different issues though because I was able to play for about an hour then it crashed on me... Dx10 ran like crap when i tried it which is funny because in crysis it runs better than DX9 for me....strange.
 

XPS M1710

Distinguished
Oct 29, 2008
5
0
18,510
0
@ Sarkamen

Ok i played far cry for about 25 mins before it crashed out and after a re-boot my pc giving me an error with my Nvidia Go 7900GS card. The Error was:

nv4_disp (The driver nv4_disp for the display device \Device\Video0 got stuck in an infinite loop.)


This has now completely fried my VGA card and is not covered under guarantee so ppl beware of this title.
 

SpinachEater

Distinguished
Oct 10, 2007
1,769
0
19,810
9
Ah, the crashes emerge. I have a 4870 but I get crashing too. In Vista 32 after about 30-45 min of playing the game will stutter for a couple of seconds then close down and I will be at my desktop. No error messages though or Vista crashing. I can start it back up and play for another 40 minutes or so.

It is strange that you NV card holders are getting it worse though. Wonder if this has to do with their pseudo DX10.1 support. I definitely think there is a stability issue with the game though. I will get massive stuttering if I bump up to 4xAA but the FPS come out fine. Sort of odd.



Do you see the BIOS screen when you start up? I have never heard of physical damage from a crash so I am just curious what state your card is in.
 

XPS M1710

Distinguished
Oct 29, 2008
5
0
18,510
0



the bios screen never appeared, i was running the latest MoBo firmware and drivers. the VGA card has gone up the spout, but i have had a new 7950 gtx 512mb ram fitted this morning so i will test again. I can't say whether it's the game or the infamous Nvidia GPU overheating issue. i have done a complete format and reinstalling atm.

read this link: http://direct2dell.com/one2one/archive/2008/08/18/nvidia-gpu-update-dell-to-offer-warranty-enhancement-to-all-affected-customers-worldwide.aspx

Once i get the game up and running via my bare bone system i will post some results.
 

XPS M1710

Distinguished
Oct 29, 2008
5
0
18,510
0
Ok after loads of updates and my new Nvidia 7950GTX 512mb VGA things are even worse

this is my system specs:

PC, Dell XPS M1710, 2Gig Ram, Nvidia 7950
GTX 512mb VGA. Dual Core Pentium T2600 2.16GHz 994MHz.

After the annoying install and sonys/Ubisofts spyware/malware nonsense, the game fired up. i went into the settings and went about lowering them all to medium and low and reducing the resolution to 1027 by 786, as i was in the settings window before i had chance to change the resolution blue flecks/blocking appeared at the top and bottom of the screen, then my system completely crashed giving me this error:

on a black screen it read:




Your system automatically shut powered off because it became warmer than expected. This may have been caused by:

0) operating or storing the system in an environment where the ambient temperature is too high, or
0) obstructing the air flow from the system fan vents.

If this problem reocurres, please call dell support with error code #M1004
strike F1 to continue, F2 to run setup.






After the error i installed S.T.A.L.K.E.R. Clear Sky and it ran on full, but slow settings for over an hour without any shut down of my system or over heating errors, i believe there is a serious problem with Far Cry 2 and needs to be addressed very soon. If not a complete recall of the title.
 

XPS M1710

Distinguished
Oct 29, 2008
5
0
18,510
0



After i played Far Cry 2 last night with the new card and got the nv4_disp error yet again, i then played crysis and it crashed with the same error, i completely removed the Nvidia drivers (using Drive cleaner Pro) and then reinstalled them, and after a night of playing crysis and stalker without a single crash or my temperature rising (monitoring with SpeedFan 4.35) i'm starting to think that Far Cry 2 is damaging the Nvidia drivers.

i am running the latest drivers for my system:
http://www.nvidia.co.uk/object/winxp_notebook_175.32_whql_uk.html

Version: 175.32 WHQL

My System is; Dell PC XPS M1710, 2Gig Ram, Nvidia 7950GTX 512mb VGA. Dual Core Pentium T2600 2.16GHz 994MHz. Win XP Home SP3.
 

Tewira

Distinguished
Oct 30, 2008
1
0
18,510
0
Played last night for 4 hours with nvidia drivers 180.43 with no problem, until I tried DX 10, laggy, no diference in visuals maybe because medium in visual, very high in performance, system specs Core 2 Duo T5570, Nvidia 8600 GT, 1200X800 resolution, on a Dell Inspiron 1520, Ranch Benchmark 26 FPS average, and have the DVD version installed, not the Steam, maybe that is the problem, never downloaded form Steam
 

deviltronix

Distinguished
Oct 31, 2008
2
0
18,510
0
I've been getting the same crash with non steam Far Cry 2, Vista 64 and 8800 GTS 2x SLI

Few things I've noticed:

Seems like the crash only seems to happen if I push the graphics settings past a certain point. (ie not on 2x anti aliasing but 4x and up)

This game runs the cards hot!!! Interestingly, it seems that the 2nd Sli card is the one it seems to really heat up (verified by reversing cards). Even more interesting is that while monitoring, the temp seemed to shoot up incredibly fast causing an almost instant crash. On 8x antialiasing, the second the fire came into view in the opening jeep ride the machine crashed.

All this coming from a watercooled rig that has never hit over 60 degrees celsius in any other games.

I would say at these temps, your hardware could be at risk. In my opinion without definite answers this game is not worth playing.

rich
 

warezme

Distinguished
Dec 18, 2006
2,355
0
19,810
20
hmmm, I have dual 8800GTX's running SLI and at native 1920x1080 FSAA2 and everthing else set to max with HDR and Bloom the game runs very well but like you guys after about 20 - 30 minutes the game begins to stutter and than I get a memory dump and the computer restarts.

Also after a restart on one occassion the system did not come back stable but would freeze opening windows and checking on CPU usage and running process showed 99% idle and no processes where locked? I had not launched any games. I had only started Outlook and Agent. I could not close anything and finally had to force shutdown.

Thinking it might have been bug related I ran full scans and my arsenal of utilities but nothing came up. Another restart and it cleared up? I have run the game 3 times and all three times it crashes after about 20 - 30 minutes. Once the audio de synced from the video and than it crashed. Another time after I ran the sleep timer and the shadows began spinning around as the time changed.

 

cliffro

Distinguished
Aug 30, 2007
1,282
0
19,660
113
I played and finished the game on Max settings in DX10, and Have played for hours at a time without so much as a system crash, the game on 1 occasion crashed but after restarting it, ran fine. I am currently playing through a second time(surprisingly the map seems different) using DX9 on max settings w/ 2xAA. (Specs in sig.)

The only driver related problem I had was 180.42's made the Editor inoperable it would crash immediately upon opening, switching back to my old drivers fixed it, I installed the game for my friend after installing his new video card and power supply(He's functionally retarded when it comes to computers, also upgraded for this game and lol Bioshock from a 7800GT) Used the 180.43's and the editor ran fine so i updated mine to them as well and it works on mine as well.

Both copies are Retail, and neither of us has had issues.
His specs are similar, E2160 @ 3ghz/GA-P35-DS3L/4gb DDR2-800/9800GTX/Vista Ultimate 64bit
I have PSU envy though, he (at my recommendation) got a Corsair TX750.

edit:
OH and both cards(8800 and the 9800) are running @ 730/1890/1000 but his memory is 100mhz faster coming out @ 2200 DDR while mine is 2000 DDR and both run very close Temp wise. Mine sees at max 56c in my colder room and his unheated shop room would provide similar since our idle temps were close.
 

warezme

Distinguished
Dec 18, 2006
2,355
0
19,810
20
I tried some of the suggestion I found on line like, disabling FSAA, forcing sync Off but it is still crashing although not nearly as bad as it only goes to the desktop now as opposed to rebooting the whole system. I also tried the widescreen fix at guru3d.com and it works really well, btw.

It must be game related as Crysis Warhammer and Stalker ClearSky run perfectly.

I game under XP32 with latest 178.24 drivers (don't want to be someone else's beta tester). My temps are not spiking on either card so I don't believe its related to overheating as I have heard others suggest. Its still a mystery but eventually someone will figure it out.
 

thacondor

Distinguished
Nov 5, 2008
45
0
18,530
0
i keep getting bsd nv4_dsp error as well... lost planet, civilization4, farcry2...i have repeatedly installed/uninstalled drivers and no luck. its not just farcry2... i think its nvidia... it happened to me in lost planet before i got farcry2 so...
 

Narr

Distinguished
Oct 13, 2008
107
0
18,680
0
Hearing a lot about these issues, did you happen to download the hotfixes and update your drivers (non-beta)?
 

Extreme43

Distinguished
Nov 6, 2008
1
0
18,510
0
Just thought i would add my 2c, i found something quite interesting.
I own a 8800GTX Extreme OC and generally underclock the card while working to about 50%. I'm running the latest nvidia BETA drivers which i downloaded about 2 days ago.

I had forgot i did this and was playing farcry 2 with mostly very high and some Ultra settings receiving around 40-50fps, not too shabby. No problems, no crashing, the game ran nicely besides the lower fps which i thought was strange (without realising the under clocked card).

I realised my mistake and reset the card to factory defaults, alas 20 minutes in-game with 1680x1050 all settings ultra-high (130fps :D) the nvidia drivers crash bringing me to the desktop in a horrible loop of driver failures. Forcibly restart the system, start up the game - 20 minutes or so in and again a crash.

I have just underclocked the card to 550Mhz Core and will try this out in the morning to see if the crashes still occur. Funnily enough whenever i select "View System Information" within the nvidia control panel i receive a BSOD.

Hopefully a newer version will be released as i was actually enjoying the game, burning the enemy out of their little huts.
 

awop

Distinguished
Nov 11, 2008
3
0
18,510
0
My system shows the same issues.

After playing the game for a very short amount of time, it crashes to the desktop with no error code or output.

The only thing I can think is that the game and drivers have a memory leak. There are so many differences in hardware and software and the only constant is the game itself. The problem is most certainly driver:game related.

We have ruled out provider: Steam and Retail DVD have the same issue.
We have ruled out video hardware: Different cards and brands, ATI and NVIDIA all have the issue.
We have ruled out OS: XP and Vista have the issue.
We have ruled out video options: All different settings in and out of game have been tried to no avail.
We have ruled out sound card options and drivers:Same reason as video options, video hardware and drivers; too many variables in brand, versions and settings with no change in results.
Drivers are most likely ruled out due to inconsistency: Beta users and non-beta users alike have the issue as well as older and newer releases of the drivers themselves.

The only known constant is that we all have the game. It is probably some poorly written code within the game engine or something of the like. We must wait for a patch while being as loud as possible the the ear of the developer: Ubisoft. Think of the things you have tried and use elimination with others as well. We are looking for constants to find the cause.

I will be watching this forum to see if anyone has figured it out. Sometimes users release fixes so keep your eyes out and keep everyone posted.

Don't forget to scream at Ubisoft for a fix. You paid for working product. I know I meet the minimum requirements and I know enough to know a faulty piece of software.

Good luck everyone.

By the way, underclocking is just as bad as overclocking; instability can be cause either way.


Games that run fine on my system on high settings include:

Mass Effect
Crysis
Sins of a Solar Empire
Counter-Strike 1.6
Counter-Strike Condition Zero
Counter-Strike: Source
Half-Life
Half-Life 2
Half-Life 2: Episode 1
Half-Life 2: Episode 2
Zombie Panic: Source
Call of Duty 4
Assassins Creed
World of Warcraft
Oblivion
Need for Speed: Most Wanted
Need for Speed: Pro Street
Dead Space
Rainbow Six: Vegas 2
Front Lines: Fuel of War
Hitman: Blood Money
Midieval 2 Total War
The Witcher
Battlefield 2
Battlefield 1942
Titan Quest
Team Fortress 2
Portal
AND MORE

My System is:

Custom Build
Asus Maximus X38 Motherboard
Intel QX6850 Quad-Core Extreme @ 3.5GHz (Water Cooling by Danger Den via 2X 120mm Radiator)
8GB DDR3 RAM
(2X) 750GB Seagate SATA2 3Gb/s
1GB Nvidia GeForce 9800 GX2
Creative SB X-Fi Fatality Platinum
Turbo-Cool 1200W PSU
Windows Vista X64 Ultimate
 
Status
Not open for further replies.

Similar threads