[SOLVED] Far Cry 3 Won't Start And Doesn't Show An Error Message

soyboy78

Prominent
Jan 22, 2018
18
0
510
0
So I bought Far Cry 3 since it was on sale for really cheap, and I had heard good things about it.
The first time I played it it worked perfectly with no problems. The issue is that I start click the desktop shortcut, then it displays the uPlay window with the Far Cry 3 icon, after that it has a bigger window with Far Cry 3 as the title, but then it shuts down the application with absolutely no error message. I have reinstalled 5 times, and whenever I verify game files integrity it says that one file is not working properly and will be fixed. I have also tried setting the compatibility to Windows 98/ Me. Please help me, it was very fun for the time that I played it.
 

nukemaster

Titan
Moderator
Some things to check.

1. Ensure your drivers are up to date. If you recently updated drivers, try the last version.
2. If you use monitoring software like MSI Afterburner or EVGA precision X. Turn those off when playing.
3. Disable Steam in game or any other on screen displays. If you use Windows 10, try to turn the game bar off.

I have notices several games as of late that did not get along with the onscreen riva tuner display that comes with MSI AB and similar software.
 

ASK THE COMMUNITY

Latest posts