FarCry 2 doesn't launch?


Oct 12, 2011
So I've had the steam version for a LONG time but never played it. I installed it, set up my graphics settings to the max, the game told me to restart to take effect. I attempted to reopen the game but I only get the splash screen for about 5 seconds and the game doesn't open.

Please help.

VisionTek 6950 CrossFire
i7 2600k
12 GB DDR3

Thanks in advance.
go into your player saves and delete the config file... 1s done restart the game and reconfigure the screen size only.
also go into your ccc panel and make sure its set to default under 3d performance.
----------------------------------------------------------- credit to original poster on steamforums for this...
Originally Posted by SgtStedanko
i fixed mine by doing this
1st shut steam down.
2nd go here C:\Program Files (x86)\Steam\steamapps
3rd Scroll Down find just cause2 main.ncf DELETE IT
4th Start steam then it will say install instead of play its dl's the file and then it works Again!! well at least for me!
i have no idea if this works for you, but it did get a few people playing.


Oct 12, 2011
@venjhammet, I have tried, doesn't work.

@Swifty_Morgan, I have steam. Updates are automatically applied.

@HEXiT, doesn't work. :(

I contacted Steam and I received this message. I tried all the steps, unfortunately these still did not work.


Thank you for contacting Steam Support.

If you are running in Windows Vista or Windows 7, please completely exit Steam, and right-click on the shortcut which you use to launch Steam and select "Run as Administrator."

If you are running in Windows XP, take the following steps:

1) Exit Steam.
2) Go to the "Start" menu, select "Run", type "regedit" and click "OK".
3) Navigate to the following registry key: HKEY_CURRENT_USER\SOFTWARE\VALVE
4) Right click and select "Permissions"
5) Check the "Allow" boxes for "Admin" and "System" for both "Full control" and "Read".

The remaining steps apply to *all* versions of Windows.

Then, verify the game's files at least once:

Title: Verifying Game Cache Files (GCF)
Link: http://support.steampowered.com/kb_article.php?ref=2037-QEUH-3335

NOTE: There may be files that fail to validate. This is normal and can be ignored.

If the issue persists, you may also need to manually run secondary installers required by this game.

First, exit Steam entirely.

Please download and install the latest DirectX update, available here:

Also, please download and install the latest version of PhysX, available here:

Then, please install the latest Visual C++ run-time components, as described in the following article:

If you have not already done so, please install the following .NET framework software packages:

You may also try the steps outlined in the "Games do not run after 'Preparing to Launch' FAQ:

As well as the "This game is currently unavailable" FAQ:

If the issue persists and this game is not made by Valve, further support for this title is handled by a third party support department:
https://support.steampowered.com/kb_cat.php?id=87 . Otherwise, please reply to this ticket if you still require assistance.


Jan 14, 2013

plz help me out me too having same issue plzz tell how did u fix it


Jul 26, 2012
Far Cry 2 is really bad, as a game. The gunplay is decent and the graphics are good, but I can't even begin to tell you the frustration you will have when you clear out an outpost and return to the same location 5 minutes later to find that every enemy has respawned. Also, literally every NPC you interact with will shoot and chase you endlessly until you kill them, only to have them respawn.

Really don't recommend the game, can't believe it got good review scores.