Fast Internet but Extremely Slow Browsing on the internet

Status
Not open for further replies.

wjsprowler

Distinguished
Jul 22, 2011
49
0
18,540
1
I am having a bit of a strange issue. I recently put together a $1,000 desktop and almost everything works great.

When I play games (such as league of legends) the online loading speeds are incredibly fast. I am usually the first person to finish.

For some reason the internet speeds when I'm on a web browser (I have tried them all) are incredibly slow. It not only takes a long time for the page itself to load, but on sites like youtube I actually have to pause the video and let it load or it will stop multiple times while I am watching.

It doesn't seem to be any problem with the internet (my previous computer had no issues at all with the internet), but with the newly built computer. Does anyone have any idea what could be the culprit of the problem?

Here is a list of the parts that I used to build my computer:

CPU: Intel Core i5-4670K 3.4GHz Quad-Core Processor ($224.99 @ Newegg)
CPU Cooler: Cooler Master Hyper 212 EVO 82.9 CFM Sleeve Bearing CPU Cooler ($29.26 @ OutletPC)
Motherboard: ASRock Fatal1ty Z87 Killer ATX LGA1150 Motherboard ($99.99 @ Newegg)
Memory: G.Skill Ares Series 8GB (2 x 4GB) DDR3-1866 Memory ($52.99 @ Newegg)
Storage: Western Digital Caviar Blue 1TB 3.5" 7200RPM Internal Hard Drive ($59.98 @ OutletPC)
Video Card: MSI GeForce GTX 770 2GB Video Card ($329.99 @ Newegg)
Case: BitFenix Shinobi Window ATX Mid Tower Case ($54.99 @ NCIX US)
Power Supply: Antec High Current Gamer 620W 80+ Bronze Certified Semi-Modular ATX Power Supply ($64.99 @ NCIX US)
Optical Drive: Samsung SH-224DB/BEBE DVD/CD Writer ($14.99 @ Newegg)
Operating System: Microsoft Windows 7 Home Premium SP1 (OEM) (64-bit) ($82.99 @ NCIX US)
 
For some reason the internet speeds when I'm on a web browser (I have tried them all) are incredibly slow. It not only takes a long time for the page itself to load, but on sites like youtube I actually have to pause the video and let it load or it will stop multiple times while I am watching.
Hi,

are you getting the problems only with videos online?
Might want to update flash player. It has been having problems lately.
 

wjsprowler

Distinguished
Jul 22, 2011
49
0
18,540
1


My flash player is currently updated, and it happens with every internet page that I load, it isn't just a problem with videos.



I'm sort of a noobie, so I don't really know what you mean when you say check my computer temps. I will disable norton antivirus and see if that has any effect on my browsing speed
 

wacabletech

Honorable
Dec 15, 2012
219
0
10,760
31
try setting your TCP/IP properties DNS entries to like OPENDNS [https://store.opendns.com/setup/] and see if that fixes it or not, if not change it back to get automatically from ISP. That would be one of the things that would differ from a gaming server, the gaming server will connect by DIRECT IP, the web uses DNS to look up IP's from things like www.google.com before connection and a bad DNS can take forever.

The other case where I see this is double NAT [which I believe if related to double NAT with double DNS, but not certain], but you'd have to be chaining routers to cause this.

 

Kewlx25

Distinguished
Oct 23, 2009
2,274
0
20,160
148


What this guy said, and to add, if you had an ad block installed on your last computer, you may want to do so on your new one.
 
Status
Not open for further replies.

Similar threads


ASK THE COMMUNITY