Question Fault with B450M-PLUS ethernet adapter?

Sep 24, 2018
9
1
15
0
So I have an intermittent problem with Ethernet on the TUF B450-M PLUS motherboard. Sometimes when I start the PC (Windows 10) the tooltray icon shows the yellow ! meaning no Ethernet. If I try and reset the adapter or disable it the PC hangs doing it - I have to force shut down. If I disable it - the PC hangs - I force shutdown and restart - I can usually re-enable the adapter and the Ethernet works. This also sometimes happens when the PC is on - the yellow ! appears and I have to go through a reset adapter involving force shutdown etc.

I have the latest BIOS and just updated the Realtek ethernet driver from the ASUS site.

Does anyone else have this problem? Any ideas please on how to solve?
 
Aug 24, 2019
1
0
10
0
I have the same board. purchased from Newegg. first one had the same problem as you. Rj45 not working, sent it back to newegg they replaced but the second one worked for about 7 hours then i noticed it was not connecting to internet or network. contacted manufacture on website and they sent me a link to download the ethernet drivers and told me if it doesnt work return the board to newegg for a refund. how about that? well obviously that didn't work. Also noticed that the green 3.5 mm sound jack on the back was not working as well. so i plugged in usb sound card it worked. front sound jack connected to the motherboard header works. so to me its the rj45 jack and the sound jack on the motherboard for sure are broken. i plugged in a little NIC card i had and it works. tried a usb to rj45 and it works. i can get usb sound from the back and the front 3.5 mm jacks so the on board sound works. sad to say but i am just going to live with it. i will be wary of this brand in the future.
 

ASK THE COMMUNITY

TRENDING THREADS