Question Feeling lag when playing fortnite on a decent pc and its already optimized

Mar 10, 2021
28
0
30
0
So I don't know what is wrong with my pc Its a prebuilt but I've changed almost everything (except the motherboard) and I don't know if that could be causing the problem but I feel a delay/lag when playing and I'm on 25 ping is so annoying I feel like it has something to do with the internet cause Im hitting blanks already got a new router but it didn't fix the problem and I have the lowest delay possible on windows 7 could it be the motherboard's lan port? I really need help because is hurting my performance
CPU: i7 8700k @ 4.6ghz
GPU: 2080msi
RAM: 16gb 4100hz
MOTHERBOARD: asrock phantom z390 I-B (I-B stands for iBuyPower some "special" model)
POWER SUPPLY: corsair 850
COOLING: nzxt x73 (temps are fine they dont go above 70c when playing)
 
Mar 10, 2021
28
0
30
0
It looks like it is an Internet issue.
The Internet issue might not be on your end...it could be an ISP router somewhere along the way.

Does it happen on Windows 10?
thanks for replying, yes I think is my internet too Ive upgraded my pc so many times thinking is the pc but Im now 99% sure is the internet cause It feels like im having packet loss I called them last month and explained my problem but they say they don't see anything wrong and that they were going to do some "rerouting" something like that and my internet felt so good but only for a couple days and it went back to feeling slow I don't know what could be causing it is also not bufferbloat think... I went from 1000mbps to like 400mbps-500mbps and also pinged google dns and no packet loss .. :c it feels so bad when playing games cause it says im on 20-25 ping but it feels like 80 and everything I do is just delayed and slow they sent a replacement router but the problem still happening I dont know what could be causing it I can only feel it when playing online games on my pc ( oh and yea it does happen on windows 10 I did so many resets trying to figure out the problem my ssd probably hates me) Im going to make a post on the networking section to see if I get a solution my ISP is at&t btw
 
Last edited:

jojesa

Illustrious
I don't think is the router.
If you run a speed test, what's the ping result?

When you PC connects to an online game, it is also connecting to a game server somewhere.
To get to that server your PC goes thru several routers.
An ISP might be able to reroute your Internet, just as someone might do when encountering a closed road or a traffic jam on the streets while driving.
The ISP might not detect your issue because they are not trying to access the server you are trying to access.
The ISP it is just checking the service and routes between them and you.

Try pinging the game server IP address.

By the way, if the ISP reroute you and it was working fine, then the lag might be caused by a router between you and the game server.
 
Mar 10, 2021
28
0
30
0
I don't think is the router.
If you run a speed test, what's the ping result?

When you PC connects to an online game, it is also connecting to a game server somewhere.
To get to that server your PC goes thru several routers.
An ISP might be able to reroute your Internet, just as someone might do when encountering a closed road or a traffic jam on the streets while driving.
The ISP might not detect your issue because they are not trying to access the server you are trying to access.
The ISP it is just checking the service and routes between them and you.

Try pinging the game server IP address.

By the way, if the ISP reroute you and it was working fine, then the lag might be caused by a router between you and the game server.

https://www.speedtest.net/result/11778007898


I did a traceroute heres what it said I think it didnt finish I dont know why is this normal??

Tracing route to qosping-aws-us-east-1.ol.epicgames.com [34.194.116.183]
over a maximum of 30 hops:



1 <1 ms <1 ms <1 ms (my ip)
2 2 ms 1 ms 1 ms 104-55-180-1.lightspeed.dybhfl.sbcglobal.net [104.55.180.1]
3 * * * Request timed out.
4 17 ms 15 ms 16 ms 12.123.34.226
5 13 ms 15 ms 15 ms 12.122.28.125
6 12 ms 12 ms 12 ms 12.123.43.209
7 12 ms 12 ms 12 ms 12.244.0.26
8 * * * Request timed out.
9 * * * Request timed out.
10 * * * Request timed out.
11 * * * Request timed out.
12 * * * Request timed out.
13 * * * Request timed out.
14 * * * Request timed out.
15 * * * Request timed out.
16 * * * Request timed out.
17 * * * Request timed out.
18 * * * Request timed out.
19 *
 
Last edited:
Mar 10, 2021
28
0
30
0
https://www.speedtest.net/result/11778007898


I did a traceroute heres what it said I think it didnt finish I dont know why is this normal??

Tracing route to qosping-aws-us-east-1.ol.epicgames.com [34.194.116.183]
over a maximum of 30 hops:



1 <1 ms <1 ms <1 ms (my ip)
2 2 ms 1 ms 1 ms 104-55-180-1.lightspeed.dybhfl.sbcglobal.net [104.55.180.1]
3 * * * Request timed out.
4 17 ms 15 ms 16 ms 12.123.34.226
5 13 ms 15 ms 15 ms 12.122.28.125
6 12 ms 12 ms 12 ms 12.123.43.209
7 12 ms 12 ms 12 ms 12.244.0.26
8 * * * Request timed out.
9 * * * Request timed out.
10 * * * Request timed out.
11 * * * Request timed out.
12 * * * Request timed out.
13 * * * Request timed out.
14 * * * Request timed out.
15 * * * Request timed out.
16 * * * Request timed out.
17 * * * Request timed out.
18 * * * Request timed out.
19 *
UPDATE* I called my isp and I talked to them about this and it fixed some of the delay :DDDDDD I still see like 4 or 5 requested timed out I dont know if thats fine or thats still bad and if so what else can I do
 
Last edited:
Mar 10, 2021
28
0
30
0
A couple of requests timeouts should be fine.
When you ping the game server, what results did you get?
Tracing route to qosping-aws-us-east-1.ol.epicgames.com [52.203.3.55]
over a maximum of 30 hops:

1 <1 ms <1 ms <1 ms (my ip)
2 10 ms 9 ms 3 ms 104-55-180-1.lightspeed.dybhfl.sbcglobal.net [104.55.180.1]
3 * * * Request timed out.
4 14 ms 15 ms 15 ms 12.123.34.226
5 13 ms 15 ms 15 ms 12.122.28.125
6 12 ms 12 ms 12 ms 12.123.43.209
7 12 ms 12 ms 12 ms 12.244.0.26
8 * * * Request timed out.
9 * * * Request timed out.
10 * * * Request timed out.
11 * * * Request timed out.
12 * * * Request timed out.
13 * * * Request timed out.
14 * * * Request timed out.
15 * * * Request timed out.
16 * * * Request timed out.
17 * * * Request timed out.
18 * *

should this be good?? the req doesnt even finish and I called my ISP multiple times and I think they can't fix it is there a way I can fix it by like buying a router not a at&t free router or switching ISPs?
 
Mar 10, 2021
28
0
30
0
A couple of requests timeouts should be fine.
When you ping the game server, what results did you get?
update* I was playing and Im now getting a ton of upload packet loss like 50-70% in game I don't know whats going on or what to do :/
View: https://imgur.com/a/TW9Q0LT
"Tracing route to qosping-aws-us-east-1.ol.epicgames.com [52.203.3.55]
over a maximum of 30 hops:

1 <1 ms <1 ms <1 ms (my ip)
2 1 ms 1 ms 1 ms 104-55-180-1.lightspeed.dybhfl.sbcglobal.net [104.55.180.1]
3 * * * Request timed out.
4 14 ms 15 ms 15 ms 12.123.34.226
5 18 ms 15 ms 16 ms 12.122.28.125
6 12 ms 12 ms 12 ms 12.123.43.209
7 12 ms 12 ms 12 ms 12.244.0.26
8 * * * Request timed out.
9 * * * Request timed out.
10 * * * Request timed out.
11 * * * Request timed out.
12 * * * Request timed out.
13 * * * Request timed out.
14 * * * Request timed out.
15 * * * Request timed out.
16 * * * Request timed out.
17 * * * Request timed out.
18 * * * Request timed out.
19 * * * Request timed out.
20 * * * Request timed out.
21 * * * Request timed out.
22 * * * Request timed out.
23 28 ms 28 ms 28 ms ec2-52-203-3-55.compute-1.amazonaws.com [52.203.3.55]

Trace complete."

called my ISP so many times and so many supervisors, they try to fix the problem but they just can't and everything is good on their end they're like "youre getting 1000mbps there shouldn't be any problem"
 
Last edited:

ASK THE COMMUNITY