Files on hard drive disappeared after RAID 1 failure

phillee53

Distinguished
Jan 26, 2012
3
0
18,510
Hi, please help... Windows 7 OS. My RAID 1 configuration on 2 x 1Tb dropped out the other week. 1 drive failed so I removed it but took me a few days to buy another one. All the data was showing as normal on the remaining working drive (here I luckily backed up the essential data) but then I rebooted and during the Windows startup screen Windows said the disc was somehow corrupted and started an automatic disc clean. Finished this and reported all good. Didn't reboot itself so I had to restart but then when it rebooted my disc was showing as empty!!! All 700Gb's of data gone!?
I thought it was something to do with the RAID so got my new hard drive and rebuild the array fine... still no data!!

One thing I did do was start a security modification to make the drive read only but on realising it was going to take a age I cancelled it. This was just before I rebooted. The drive was in read-only mode but I have now switched it back to read and write using diskpart.
The drive still had some really important data on it that I would really like back....
I would really appreciate any help?
Thanks Phil
 

phillee53

Distinguished
Jan 26, 2012
3
0
18,510
- SOLVED -
I took the drive to a recovery firm in the end. Seems the Windows 7 automatic disk repair on re-boot destroyed the file system of my drive. So nothing to do with the RAID 1 array. The guy at the recovery firm said he'd seen this before. All my data was recoverable so ended OK.
Good to be careful with the Windows disk repair...