Question Final update on Power Mac G4

ragnarok0274

Great
Sep 12, 2020
172
9
95
3
I know that the mods and me haven't had a good relationship over this thread.
But.
I figured out the problem.
It was the optical drive.
Backstory to how I got this computer:
When I first got this, with three other computers, I took them all apart.
Every single part (except the CPUs and motherboards, those stayed together) was strewn across the basement floor.
Well, it was time to clean up, so I put two back together: the Power Mac G4 and my Pentium III/Win98 tower.
The Win98 was first, and I decided to put the Power Mac's optical drive in as it was the only beige DVD-ROM drive I had.
Well, I ran into booting problems, so I disconnected everything except the HDD from the IDE ports (I had the DVD-ROM and my Creative 48x connected to the secondary, with the HDD connected to the primary.
Made it to the BIOS and ran into bus synchronization, fixed that, booted to 98.
Added back the Creative, worked fine.
Added back the DVD-ROM, it didn't. I assumed this was "Apple" part in non-Apple computer.
So I took it out and put it back in the Power Mac. I had looked at - and wiped all but the 98 HDD because my 98 CD was scratched. I wasn't able to read anything on the G4 HDD, because, well, HFS(+).
Fast-forward to October. It was put back together and I was trying to fix it. It wasn't booting anything, and I thought it was the PMU because I had accidentally pressed that button a few times. Except, it wasn't.
It was the optical drive.
I have a different DVD-ROM drive in there now and it is installing Mac OS 9 as I type this.
So, yay?
Also, now I have the rainbow wheel of death, 1999 edition.
I think my optical drive just sneezed.
 

ASK THE COMMUNITY

TRENDING THREADS