Question First Build Help: MSI B450 max 2 not detecting WD sn850 m.2

Mar 25, 2021
4
0
10
0
Hey all. I dove into my first ever PC build with some guidance from friends. My motherboard is not detecting the m.2 drive in bios so I can't move forward. The MB recognizes my hand-me-down SATA optical drive, but I don't have any other drives to test out.

MB: MSI B450 Tomahawk Max II w/ Ryzen 5 3600
m.2: WD sn850 500gb

Can anyone help this noob out?
 
Mar 25, 2021
4
0
10
0
Likely you have plugged the optical drive into a reserved SATA slot which shares bandwidth with the M.2 slot. Move the optical drive (or unplug just to test) to another SATA port.
Negative. I am not using the reserved ports (5 and 6), and the problem exists even after completely unplugging the sata drive.
 
Mar 25, 2021
4
0
10
0
Also it could be BIOS. Some Ryzen BIOS versions had problems with m.2 ssd.
What is your Bios version?
I downloaded and flashed to 7C02vH4, 2021-02-09, from the MSI website. The bios itself says it is E7C02AMS.H40, 2021-02-03. I assume those are the same, but I did not note what the version was before i flashed it.
 
Mar 25, 2021
4
0
10
0
Hmm, usually see large warnings about updating the BIOS too far when using an older CPU. Those recent BIOS are for the 5000 series.

Yeah, not sure on this one. Could be a bad drive or motherboard.
Would flashing to an older bios be worth trying? Without having another m.2 drive, any suggestions on how to test the board slot? Or test the m.2 card without another board? I could check if a repair shop could at least test my drive to see if it works.

Troubleshooting things like this is why I was always too nervous to build a machine myself.
 

Eximo

Titan
Ambassador
I usually point people to repair shops when they have new components that don't seem to work. Really the only way unless you have friends who have recently built computers and want to take on the risk.

Nice shop people might even diagnose for free on a slow day.
 

ASK THE COMMUNITY

TRENDING THREADS