Question first build: power cycling every 20 seconds

Dec 28, 2019
2
0
10
0
We just built our first PC (with help from a friend who has built several), and we're encountering an issue where it will power on (chassis fans spin, LED on the CPU fan lights up, blue GPU light goes on), and then power down after about 20 seconds. It'll then power on again, then power off 20 seconds later in a neverending cycle. No other audio or visual clues as to what might be going on. I don't have any speakers connected: have just been trying to boot it up with a monitor atttached to the HDMI input (tried both the mobo HDMI and the GPU HDMI, neither worked).

Parts:
  • ASRock B450m/ac mobo
  • AMD Ryzen 7 2700x CPU
  • XFX Radeon RX 580 GTS XXX Edition
  • Rosewill ATX Mid Tower case (Prism S Black Lite)
  • Rosewill Glacier 850W PSU
  • Cooler Master 212 RGB Black ed fan
  • Inland professional 480GB SATA SSD
  • G.Skill Ripjaw V 16GB RAM (2x8gb) DDR4 3200 (mounted in A2 and B2 slots per manual)
I've tried booting with one stick of RAM (and the other), and in different positions, but get the same issue. Also tried various configurations of the reset button and power switch to the system panel header (there are 2 cables for each and the manual isn't very clear on how to attach them). Settled on having the + connector for each attached to the pin designated in the manual, and the - connector attached to a ground.

I'm running out of ideas and hoping the internet has some answers.
 
Dec 28, 2019
2
0
10
0

ASK THE COMMUNITY

TRENDING THREADS