Question First PCIe x16 slot and Onboard GPU not functional

Jan 22, 2020
I have heard the POST alarm NO VGA (1 long 3 Short beeps) from the mother board and seen “No signal” on my screen a lot lately.
The system works as a dream with the ASUS Cerberus GTX 1050 Ti in second PCIe slot, so no failure in GPU or cables.
I have built many rigs an newer seen this kind of issue – first thoughts where Mobo failure but searches via Google looks like others have the same issue – also on this site
This rig first started with the GPU in Slot 2 because I wanted more air around the CPU cooler so I never got the error from the beginning – I did not notice Win 10 did not detect the Onboard GPU.
Enter a new GPU with more power (ASUS TUF RTX5700) and much bigger. It could not fit in to Slot 2 due to conflicting space where SATA 4-6 and other board connectors are located.
It only could fit in to Slot 1 and then I got no VGA alarm. Thinking the GPU had a failure I tried with the old GPU – No VGA. Also with no GPU’s in Slot 1 & 2 I get No VGA ???? And according to specs this board does have an onboard VGA. I get the alarm during POST so before the OS WIN 10 64bit starts. And with NO VGA I also never see the BIOS Screen on the monitor – just black screen and the monitor shows “No Signal” and the goes to sleep again.
With the old GPU in slot 2 is the only way this Rigs works – and that is with no issues what so ever (exept a slightly outdated GPU)
My set up is:
ASUS TUF Z390M-Pro Gaming
i5 9400 F
2x4GB HyperX Furry
ASUS Cerberus GTX 1050 Ti
Kingston SSD SUV240
Samsung SSD 850 EVO
700 W PSU
Bios updated to 2606

I have tried a lot … also resetting CMOS and removing the battery for a while … even attempting to boot with all SATA connections removed – only keyboard & monitor and still only POST screen in the setup with old GPU in Slot 2 …. With this “Native” setup I did not even see a POST screen from the Onboard GPU….
When I see the BOIS setup even in the stripped setup (GPU in Slot 2) I never have seen anything about onboard GPU…
I’m going crazy …. Next step I guess is RMA… I did raise a case with ASUS, so I will also see I they come up with an answer, BIOS update … or magic.
From what I see on searches this seems to be something other have experienced – but not really solved – this pointing towards a more general issue with setup or weak spot on the mother boards … some failure with the same symptom
Any ideas are appreciated
Jan 22, 2020
Thanks Jay,
As I understood my motherboard has a Onboard GPU - correct me if I'm wrong.
Again reading the specs... I could be wrong and I should interpret this as the MB will support if the CPU has a GPU built in

Integrated Graphics Processor- Intel® UHD Graphics support
Multi-VGA output support : HDMI/DisplayPort ports
  • Supports HDMI with max. resolution 4096 x 2160 @ 30 Hz
  • Supports DisplayPort with max. resolution 4096 x 2304 @ 60 Hz
Supports Intel® InTru™ 3D, Quick Sync Video, Clear Video HD Technology, Insider™
DP 1.2 Multi-Stream Transport compliant, supports DP 1.2 monitor daisy chain up to 3 displays

That I guess would explain the "No VGA " alarm and then I'm back to only focus on the Slot 1.

The qustions is then if there could be any BIOS setting that could block the recognition of a functinal GPU card.
Jan 22, 2020
"Integrated Graphics Processor- Intel® UHD Graphics support"

That means it "supports" UHD Graphics if you have them.
Yep - Got that one now - Thanks

My suspesion regarding the port 1 (If it is not faulty or dirty) is about the PCIe Speed setting in BIOS [Auto] [Gen1][Gen2][Gen3] - It is on auto now and it could be a misscom there. I cant find much regarding [Genx].
Last edited: