Info ##FIXED### Stutter/Freezing and black display issues for Asus Phoenix GTX 1660 Super

Sep 15, 2020
2
0
10
0
Hi,

My PC is has the specs below.

Intel Core i5-9400F 2.9 GHZ 9MB
ASUS PRIME B365M-A
ASUS GTX 1660 Super Phoenix DDR6 Dual Evo
SSD Corsair M.2 NVMe MP510 480GB
G.skill Ripjaws V 16gb ddr4-3200mhz
PSU Sharkoon WPM Gold Zero 550Watts
Case: Gamax Case ATX G517 Shine
Deepcool Gammaxx 300 LED CPU Cooling fan- 120 mm
Deepcool RF120 120mm RGB LED PWM Fan
ezdiy-fab 3-pack 120mm RGB
Monitor: 34'' LG 34wk650 ultrawide 75hz

Bought and assembled last March 2020.

I need your help with my RIG please.

Im experiencing some issues with sudden black screen and saying display not found. And on the other hand some sort of freezing/stuttering for about 2-3 secs, that both are happening randomly(e.g. playing monster hunter world, watching movies, browsing, etc). By the way, whenever this is happening i hear a sound, it's like an HDD loading or some sorts.

I have tried the following for now but issues still persists:
  1. uninstalled and reinstalled display driver (DDU tool)
  2. changed up to 3 HDMI cables and 1 Displayport.
  3. tried this fix from the link:
    View: https://www.youtube.com/watch?v=xzwuszbJCPM&list=PLPwwfyq0Mhx7csRcxUunKwWUG8jbVT_8I&index=9
  4. gpu Driver Is up to date.
  5. Tried MSI afterburner.
  6. Tried to use another monitor.
While gaming GPU Temp max's at 83 celsius.
CPU doesn't max at 100%
Sample videos saved in my google drive: https://drive.google.com/drive/u/0/folders/1WkE9pAJcX4IUSdhZHvFpqB_fICGV09t7

I hope you all can help me.

Thank you.
 

ASK THE COMMUNITY

TRENDING THREADS