Question Flickering on models on laptop.

Chasingfaith

Reputable
May 7, 2016
190
9
4,765
49
This kind of artifacting is usually caused by either a bad graphics card or a bad overclock. Seeing that this problem is occurring in all your games now, your gpu might be dying on you... You should switch to your integrated graphics (in the Nvidia control panel) to check if the problem persists. If it doesn't, your dedicated gpu is most likely to blame and unfortunately, there isn't much you can do about it unless you still have a warranty.
 
Apr 3, 2019
3
0
10
0
This kind of artifacting is usually caused by either a bad graphics card or a bad overclock. Seeing that this problem is occurring in all your games now, your gpu might be dying on you... You should switch to your integrated graphics (in the Nvidia control panel) to check if the problem persists. If it doesn't, your dedicated gpu is most likely to blame and unfortunately, there isn't much you can do about it unless you still have a warranty.
I still have the warranty for 135 more days, I just checked. I switched it to [cpu] and it is still doing it. I've turned on Vsync and all that good stuff and it hasn't changed at all. So I should just send it back?
 

Chasingfaith

Reputable
May 7, 2016
190
9
4,765
49
If the problem persists with your integrated gpu, that means that your dedicated gpu is not to blame.

Are you sure that you didn't only change your PhysX to "cpu"? In this case, you might still have been using your dedicated gpu. To use your integrated graphics, you should go to "manage 3D settings" and change "preferred graphics processor" to "integrated graphics". You should see a massive decrease in performance when running your games.
 
Last edited:
Apr 3, 2019
3
0
10
0
If the problem persists with your integrated gpu, that means that your dedicated gpu is not to blame.

Are you sure that you didn't only change your PhysX to "cpu"? In this case, you might still have been using your dedicated gpu. To use your integrated graphics, you should go to "manage 3D settings" and change "preferred graphics processor" to "integrated graphics". You should see a massive decrease in performance when running your games.
Ok so yes, I changed it to integrated graphics, the problem went away. But i bought the computer to play games on. Is there a way to fix it? Or just send it back?
 

Chasingfaith

Reputable
May 7, 2016
190
9
4,765
49
I understand that you don't want the use the integrated graphics on your gaming pc. I only suggested its use to check if the dedicated gpu was causing the issues.

In your case the problems went away when switching to the igpu, meaning that your dedicated gpu is almost certainly the cause of your problems. Unfortunately there is no way to fix this problem because it is hardware related. The only "solution" would be to send it back.
 

ASK THE COMMUNITY

TRENDING THREADS