• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Meet Stan Dmitriev of SurrogateTV on the Pi Cast TODAY! The show is live August 11th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Professional PC modder Mike Petereyns joins Scharon on the Tom's Hardware Show live on Thursday, August 13th at 3:00 pm ET (8:00 PM BST). Click here!

Question Focusrite Scarlett Solo 3rd gen has constant popping sound on a loop.

Jul 6, 2020
2
0
10
0
All of a sudden my Interface started making this horrible popping sound that seems like it on a loop. Focusrite control and windows both think the device is working properly but it won't play any sound from windows and the popping sound is still playing. I tried connecting different USB cables, using different slots, resetting my CMOS, different sample rates, installing the latest drivers, everything. It won't work. Whenever I turn on the computer it will even make the sound when I haven't logged into windows yet. The problem is isolated to the interface. The problem started when I was in FL Studio 20 and I was disconnecting a microphone and adding a new one. Please if you have any solutions help, the sound is driving me insane
 
Jul 6, 2020
2
0
10
0
Did you contact Focusrite support? A lot of people skip that important first step.

Test it on a different computer to rule out your system?
I did a test on a different system. The issue still persists. I think I found the issue though. When i was switching mics i had phantom power on and i must've friend my interface somehow.
 

ASK THE COMMUNITY

TRENDING THREADS