[SOLVED] Foggy 1080p display when set to Ultra HD

Apr 5, 2019
14
0
10
0
Nvidia control panel gives me two resolutions to choose: One under the PC category 1920x1080 at 75hz, which looks better to me. However, the second option under Ultra HD gives 1920x1080 at 60hz, which is what i want, but whenever i select this resolution, the display seems more whiter than at 75hz. I really want to load up 60hz, but it makes the screen a little brighter and foggier than usual. Setting up custom resolution under PC category for 60hz quotes that i'm trying to make a duplicate resolution. I want to make the screen work at 60hz but the picture being like that at 75hz: more clearer. Any help would be appreciated.
 
Nvidia control panel gives me two resolutions to choose: One under the PC category 1920x1080 at 75hz, which looks better to me. However, the second option under Ultra HD gives 1920x1080 at 60hz, which is what i want, but whenever i select this resolution, the display seems more whiter than at 75hz. I really want to load up 60hz, but it makes the screen a little brighter and foggier than usual. Setting up custom resolution under PC category for 60hz quotes that i'm trying to make a duplicate resolution. I want to make the screen work at 60hz but the picture being like that at 75hz: more clearer. Any help would be appreciated.
You need to change the Output Dynamic Range to Full.

View: https://i.imgur.com/aEnlBkH.png
 

Darkbreeze

Titan
Moderator
You do not want the setting under Ultra HD. You want the setting under "PC". And then to the right, set the refresh rate to exactly the advertised refresh rate of your monitor. If your monitor is a 75hz panel, set it to 75hz. Some panels simply do not work correctly when set to refresh rates other than what they were designed for.

My LG for example looks like crap at anything other than 120hz or 144hz and neither of those refresh rates work properly if I select any 1440p setting under Ultra HD, HD, or SD, only under PC.

Things should be smoother at 75hz anyhow, so not sure why you'd want to set it to 60hz. If it's a tearing problem and you don't have a Freesync or Gsync display, then you can always try using v-sync from the Geforce experience settings. I'm assuming this is mainly for gaming or is this not gaming related?
 
Apr 5, 2019
14
0
10
0
You do not want the setting under Ultra HD. You want the setting under "PC". And then to the right, set the refresh rate to exactly the advertised refresh rate of your monitor. If your monitor is a 75hz panel, set it to 75hz. Some panels simply do not work correctly when set to refresh rates other than what they were designed for.

My LG for example looks like crap at anything other than 120hz or 144hz and neither of those refresh rates work properly if I select any 1440p setting under Ultra HD, HD, or SD, only under PC.

Things should be smoother at 75hz anyhow, so not sure why you'd want to set it to 60hz. If it's a tearing problem and you don't have a Freesync or Gsync display, then you can always try using v-sync from the Geforce experience settings. I'm assuming this is mainly for gaming or is this not gaming related?
Its for a recording issue i get under 75hz, making the playback somehow choppy. All works fine under 60hz, that's why.
 
Nvidia control panel gives me two resolutions to choose: One under the PC category 1920x1080 at 75hz, which looks better to me. However, the second option under Ultra HD gives 1920x1080 at 60hz, which is what i want, but whenever i select this resolution, the display seems more whiter than at 75hz. I really want to load up 60hz, but it makes the screen a little brighter and foggier than usual. Setting up custom resolution under PC category for 60hz quotes that i'm trying to make a duplicate resolution. I want to make the screen work at 60hz but the picture being like that at 75hz: more clearer. Any help would be appreciated.
You need to change the Output Dynamic Range to Full.

View: https://i.imgur.com/aEnlBkH.png
 

ASK THE COMMUNITY

TRENDING THREADS