Question For clevo seger P170EM updated BIOS Windows 10 22H2

Apr 30, 2021
5
0
510
0
So an old friend of mine and myself have been working on this build off and on for a little over a year and we got the GPU BIOS updated from the manufacturer and sometimes it will show that it's working sometimes not but I noticed that nearly all or all of the hardware in the hardware manager shows needs further installation and it says something about a subnet or a sub windows system I'm not sure which one it was referring to but if anyone's run into this problem before.

I could sure use any ideas or suggestions on which direction to take it after I post this

When I get a minute I will jump on my desktop and see if I can post some screenshots or something whatever anybody thinks they will need I'm not very familiar with the software on the machine I know the BIOS version is the only one it can update to which I believe he said was the only way to get the GPU BIOS to reinstall but that's a little over my head.

If anyone has any suggestions and need screenshots or system information I should be available in a few hours to post any and all information you need to help me get this monster figured out it's a 2011 clevo Sager P170EM with a Nvidia 4 gig GPU I don't recall what its designation was but again the issue is with Windows needing further installation on all hardware.
 
Apr 30, 2021
5
0
510
0
Update I checked the hardware after I did as much manual driver installation as I could on all of the hardware including the GPU and it was still saying requires further installation on some of the stuff but then I remembered that I needed to download additional Windows software like in that folder tree drop down menu and almost none of it was installed so I installed legacy I installed the TCIP everything that was relevant and then I did a quick backup and then started downloading it and after it reset the GPU and CPU fans were on high for about 3 minutes solid with a blank screen and then blue screen of death so there's got to be some clues in there I've got a terrible headache right now so if I don't fall asleep soon I will get some screenshots and system overviews and maybe even crash reports if you guys can walk me through it again thank you so much for your help, I was told that the onboard mouse pad needed to be replaced or fixed and I took the machine apart 90% over 30 screws very meticulously and cleaned everything reinstalled the hardware for the GPU and updated Windows after I reconnected a ribbon wire from the buttons to the touchpad of the mouse parentheses whoops got it all put back together downloaded world of tanks blitz play the game or two after the GTX 675 MX graphics card with showing not working again but I just disabled it re-enabled it and it had the error message go away so I tested it on world of tank blitz and of course it was able to play it but it was using the onboard GPU so that's when I remembered it needed some windows updates I was thinking c++ redistributable for some reason those stuck out in my head is in all my other builds have that but this one didn't
 

ASK THE COMMUNITY