Question Force 144hz to avoid ghosting ?

Dec 15, 2019
1
0
10
0
Hello everyone,

I just purchased an ASU ROG Zephyrus:

  • CPU I7 9750H
  • 16g rams
  • GPU GTX 1660Ti
  • Screen 144hz
So, after booting the laptop I noticed heavy ghosting while scrolling websites (high contrast). Let's say I have a blue background on the entire screen, with written: TOMSHARDWARE in a huge format in white... now if I scroll down or up, TOMSHARDWARE will leave a trail (black trail) kind of like a shadow... which gets really annoying and very not pleasant while I navigate online.

After little use I noticed it only happens noticeably when my computer is unplugged. I understood that when the computer is not charging or plugged the screen is at 60hz and when its plugged it's at 144hz.

So, my technique, to go around when I am not charging is to go to the settings and force my computer at 144hz.

I have two questions following what I just said above:

  1. is there a way to always force my pc to 144hz ? Each time I plug and unplug it sets back to 60.... it gets annoying to set it all the time.
  2. is there another solution? While setting it to 144hz seems to do the trick... it does not do it completely... I still get shadows, trails or ghosting effect... but it gets usable..
If any other users has experienced that and has a workaround... i'll take it.

Thanks a lot.
 

ASK THE COMMUNITY

TRENDING THREADS