Question Fortnite micro tearing.

Aug 20, 2019
38
0
30
0
  • CPU: Ryzen 5 1600x.
  • GPU: MSI GAMING Radeon RX 470 GDDR5 4GB
  • PSU: Corsair™ CX550M — 550 Watt 80 PLUS® Bronze Certified Modular ATX PSU
  • Motherboard: ASUS B350 Prime version 8901
  • Ram: CORSAIR VENGEANCE® LPX 16GB (2 x 8GB) DDR4 DRAM 3200MHz
  • OS: Windows 10 Pro
PC jumps between 300 and 60 frames. Causes notable lag. Everything on low. Tested everything on high and it still does the same shit.
 

ConanLock

Commendable
May 22, 2019
1,117
238
1,240
38
A few things to check:
• Have you enabled XMP (or DOCP as it might be called) in the BIOS, then set the automatic specs to 3200MHz if applicable? If not, do that now, as this will get the RAM running at full speed. It should be with other overclocking settings.
• Is the RAM in slot 2 and 4? If not, change it, so that it goes empty, RAM, empty, RAM. This effectively doubles the bandwidth of data to the CPU.
• Are the newest drivers for the RX 470 installed? If not, uninstall the ones you have, then get the newest ones available from AMD's website. Don't use the ones that came with the disc, if you got one, as these are outdated.
• Is the monitor plugged into the graphics card or motherboard. It should always be plugged into the graphics card when one is available.
 
Aug 20, 2019
38
0
30
0
A few things to check:
• Have you enabled XMP (or DOCP as it might be called) in the BIOS, then set the automatic specs to 3200MHz if applicable? If not, do that now, as this will get the RAM running at full speed. It should be with other overclocking settings.
• Is the RAM in slot 2 and 4? If not, change it, so that it goes empty, RAM, empty, RAM. This effectively doubles the bandwidth of data to the CPU.
• Are the newest drivers for the RX 470 installed? If not, uninstall the ones you have, then get the newest ones available from AMD's website. Don't use the ones that came with the disc, if you got one, as these are outdated.
• Is the monitor plugged into the graphics card or motherboard. It should always be plugged into the graphics card when one is available.
  • The ram is at 2400mhz.
  • Yep, slot 2 and 4.
  • Newest drivers.
  • The RX570 does have two slots so yes, indeed it is plugged into the card.
RX570 btw sorry, not RX470.
 
Screen tearing comes from mismatched monitor and gpu frame generation capabilities.

If the gpu can generate frames faster than the monitor can accept them you can get screen tearing.
If you can implement vsync, your frame rate will be limited to what the monitor can accept.
There are also good solutions using triple buffering techniques.
I do not know if your drivers can use that.

Here is a good article about latency and tearing.
https://www.anandtech.com/show/10325/the-nvidia-geforce-gtx-1080-and-1070-founders-edition-review/13
It applies to nvidia 1000 series cards and later; I do not know the amd equivalent other than fast sync.
 
Last edited:
Aug 20, 2019
38
0
30
0
A few things to check:
• Have you enabled XMP (or DOCP as it might be called) in the BIOS, then set the automatic specs to 3200MHz if applicable? If not, do that now, as this will get the RAM running at full speed. It should be with other overclocking settings.
• Is the RAM in slot 2 and 4? If not, change it, so that it goes empty, RAM, empty, RAM. This effectively doubles the bandwidth of data to the CPU.
• Are the newest drivers for the RX 470 installed? If not, uninstall the ones you have, then get the newest ones available from AMD's website. Don't use the ones that came with the disc, if you got one, as these are outdated.
• Is the monitor plugged into the graphics card or motherboard. It should always be plugged into the graphics card when one is available.
PC crashes when ram exceeds 3000mhz. It reboots 3 times before resetting itself to 2133mhz. Currently running at, and will test at 3000mhz. Vsync makes the frames even more jumpy and it feels like im running 10 fps.
Screen tearing comes from mismatched monitor and gpu frame generation capabilities.

If the gpu can generate frames faster than the monitor can accept them you can get screen tearing.
If you can implement vsync, your frame rate will be limited to what the monitor can accept.
There are also good solutions using triple buffering techniques.
I do not know if your drivers can use that.
My main monitor is an ACER K222HQL overclocked to 74hz. Vsync seems to help a tiny bit but there is still a bit of debatable lag. Is the K222HQL and RX570 not compatible? How do I check for tripple buffering techniques?
 
Aug 20, 2019
38
0
30
0
Try using MSI Afterburner (more specifically, RivaTuner that comes with Afterburner) to lock FPS to 74, and see if this works, and turn VSync off
Locked it at 74, same issue. The FPS keeps falling under 74 and causing lag. I tried putting the power limit to max, it was locked at 74 stable but the mouse movement seemed soo weird and slow.
 

ConanLock

Commendable
May 22, 2019
1,117
238
1,240
38
Do you use anything like unofficial driver downloaders, system optimisers or speed boosters? If so, it might be worth just resetting Windows to factory settings.

If not, download Malwarebytes and do a full scan, removing anything it finds.
Next, click on the start menu, and search for CMD. Right click Command Prompt, and choose Run as Administrator. Here, type sfc /scannow and hit enter. Wait for the whole thing to complete.
If there is a hard drive in the system then click on the start menu and search for defrag. Click on the optimise drives program. Analyse your hard drive and once finished optimise (defragment) it. Do not do this on any SSD or SSHD drives.
 
Aug 20, 2019
38
0
30
0
Do you use anything like unofficial driver downloaders, system optimisers or speed boosters? If so, it might be worth just resetting Windows to factory settings.

If not, download Malwarebytes and do a full scan, removing anything it finds.
Next, click on the start menu, and search for CMD. Right click Command Prompt, and choose Run as Administrator. Here, type sfc /scannow and hit enter. Wait for the whole thing to complete.
If there is a hard drive in the system then click on the start menu and search for defrag. Click on the optimise drives program. Analyse your hard drive and once finished optimise (defragment) it. Do not do this on any SSD or SSHD drives.
It was the refresh rate. Every time fortnite launched; it changes to 59hz. Changed it to 60hz and now it's "better",
 

ASK THE COMMUNITY