[SOLVED] found fix for slow tabbing in/out but it always stops working

kilo24

Reputable
Jan 31, 2019
79
1
4,545
1
for certain games in windows 11, tabbing in and out makes me have to wait through a black screen for about four seconds each time (ive seen claims this is from the refresh rate or resolution changing?). ive found this to hamper my entire daily user experience by making it feel sluggish and tedious, since i play these games often. after scrounging around online and finding many different solutions that did and didnt work for different people, setting the scaling mode to either "integer scaling" or "no scaling" seemed to solve the issue

however, after turning my pc back on the next morning, my problem was back, and this fix no longer worked. i did a clean reinstall of my graphics drivers, which fixed it again, but THIS morning its returned once more. what confuses me the most is that i tested turning power cycling my machine yesterday, and my alt-tabbing remained fine, so it seems like it takes a certain amount of time before breaking. i get the strong impression its very hard to keep this behaviour at bay for good; many of the experiences reported by others around search results i mentioned seemed to imply it almost inevitably comes back some mysterious way or another

ps: for some programs (eduke32) this makes my hdr very washed out. it has to be fixed by toggling it off and on in windows settings

specs:
27gl850-b monitor, 1440p@144hz
rtx 2080 (though i'll be upgrading to a 3080 10gb soon)
core i9 9900k
2x8 ddr4
 

Colif

Win 11 Master
Moderator
Jun 12, 2015
60,154
5,028
166,290
10,408
what confuses me the most is that i tested turning power cycling my machine yesterday, and my alt-tabbing remained fine, so it seems like it takes a certain amount of time before breaking.
that is odd. I wonder if fast start up is on
search for control panel
set view to big icons
open Power Options
click Choose what the power button does
Turn on fast Startup
should be off in win 11 but if its on & greyed out
click Change settings that are currently available next to the shield
untick Turn on fast startup
Save changes

It should be off by default in Win 11 & if you have an nvme its not needed or helpful.


another thought is your screen scaling settings might be saved to an online profile and it resets them on logon... but I would think this would happen every logon and not just after a given amount of time.
can turn that off in Settings/Accounts/Windows Backup
Remember my preferences


down bottom of this page shows how to clear the roaming profile that could be the cause - https://support.microsoft.com/en-us/windows/about-windows-backup-and-sync-settings-deebcba2-5bc0-4e63-279a-329926955708
 

kilo24

Reputable
Jan 31, 2019
79
1
4,545
1
i disabled fast startup as well as the windows backup thing, but i cant tell if the roaming profile deletion worked; it either gives me no feedback whatsoever before refreshing the page or takes me to an error screen. sorry for not testing these fixes one at at time, by the way. i realise it eliminates the control factor, but i dont think i have the energy or patience to wait a day or so at at time to see if each one works

this bug also seems to happen regardless of my scaling settings, actually. no combination of them fixes it while its present, but after reinstalling my graphics driver again, no combination can break it. and as implied by the previous sentence, i also reinstalled those and rebooted again, even waiting a few minutes beforehand. i'll try to remember to update on whether or not this sticks
 

kilo24

Reputable
Jan 31, 2019
79
1
4,545
1
after booting up my pc today i can confirm the issue is still gone, thanks a lot for your advice so far. it still might come back later, but i'll be sure to run DDU if i have to reinstall again. i've also paused windows updates, would be a shame to get those bugs when my 3080 should be arriving any day now
 

ASK THE COMMUNITY