Question FPS drops after a few minutes but was normal yesterday ?

Man1ac123

Honorable
May 11, 2015
32
0
10,530
0
TLDR:
View: https://youtu.be/xZiqNtN-V1g?t=34
Basically this happens, The game is smooth for a minute and then drops to 10fps.

PC specs:
i5 - 4690K
GIGABYTE G1 GAMING GTX 970
GA-Z97P-D3
Kingston DDR3 HyperX FURY Black 2x4GB 1600MHz
1TB WD
480GB SSD CRUCIAL
XFX TS 550W

Long story.
I tried everything and i'm going to try to list it all.
Started playing Witcher 3 recently and the game ran fine in the first day, the next day I started getting these parts of the game where I had 20 fps and I started changing graphic settings but it didn't change anything. I even tought it was because of the rain that was pouring in game.
The next day I verified the game files with steam tool. It seemed to work and on saturday I played all day no problems. I created that habbit of verifying game files before running the game because it looked like it worked.
On monday I started Forza Horizon to do a daily challenge and the same thing happens. I start to worry it's all games. And it was, PUBG, Sea of Thieves, they also had fpd drops after the first minutes.
I spent all day doing all the methods mentioned online:

-Updated driver? yes
-DDU the current driver and clean install? yes
-Roll back nvidia driver? yes
-Check CPU and GPU temperatures? yes the usual 50ºC on CPU and 60ºC on GPU
-Check Task Manager for any weird programs using cpu gpu? not sure, I see witcher using all ofthe gpu which is fine I think
-Deactivate antivirus? yes and added the exception for all steam games in the process
-Ran malwarebytes to check for malware? nothing came up
-Check windows update? had some pending ones so I did them all
-Ran memory check? yes
-Windows files check? yes
-Redownloaded windows redistributables? yes
-Uninstalled Witcher and reinstall? yes
-Power plan on control panel is on maximum performance? yes

and probably did more stuff but can't remember now.
I quit and the day was almost over. After some restarts and shutdowns the games started running fine. Weird Weird Weird.
Played all day today too but now it started again. The video shows what happened minutes ago.
I'm out of ideas and I wanted to see if any of you guys can look into my problem and try to think of a solution while I get some sleep.
 

keith12

Illustrious
Hey there,

It's possibly ram related. You might try running memtest86+ and test your ram outside of windows. Also, 8gb of ram is barely enough nowadays and in most cases for some of those games, would cause stutter. If your ram fills up (keeping in mind some ram is reserved for hardware), you often have only 6.5-7gbs of system ram available to game. Once it fills up it starts to use the swap file/virtual mem - which is much slower than ram - and this causes the stuttering.

I'd suggest getting a 2 x8 gb matched kit. I suspect that will solve your issue.
 

Man1ac123

Honorable
May 11, 2015
32
0
10,530
0
Sorry for the late reply and thanks for your input.
Yesterday I spent all day resetting the pc. Fresh new install since I didn't do one for a while. So far I played Forza and Battlefield with no issues and I started playing Withcer right now and let's see how it goes.
If the issue comes back I'll try your solution because I also think that my RAM is the weak point of my build. Back in the day ddr3 was almost in the end and ddr4 was showing up with better speeds, but I wanted the 50€ price tag on every small component.
Let's hope pc parts prices drop by the end of the year so I can get better parts.
 

ASK THE COMMUNITY