Question FPS DROPS AFTER COMPUTER IS ON FOR FEW HOURS

Dec 1, 2020
33
0
30
0
Hello, I have a i7 4790k and gtx 970 msi... The only game I play is starcraft brood war and I never had any problems with fps ever dropping under 300 while playing that game for years but just not to long ago about 3-4 weeks ago when I first start up my computer my fps are good even after 2-3 hours of playing starcraft bw my fps are consistent 300 but after some hours or playing they drop under 200 and every click I make or movement with mouse it keeps dropping under 200 and the game gets slightly laggy I tried everything gpu update and many other things but nothings fixed it the only way I can fix the problem once It drops under 200 is restart the computer. Sometime it drops under 100 fps as well after several hours of computer being on. Please if someone can help me =(
 

jay32267

Illustrious
That shows your CPU temps are good at full load...which is good.

The GPU however...only reached 16% usage.

You want to get it near 100% usage and look at the temp.

What power supply?

Have you looked at voltages with HWInfo?
 

jay32267

Illustrious
Yeah....that's what you want.
The three voltages 12,5 and 3.3 all look good.
...and that PSU you have...is a pretty good one.
...and you can see it gives you temps too.

Now I would keep HWInfo running....

and run the game....until it's doing this>>>

"but after some hours or playing they drop under 200 and every click I make or movement with mouse it keeps dropping under 200 "

THEN....I would close the game and look at HWinfo.

Because "during it acting up" is when it would have captured the "low voltages" or "high temperatures"....IF they are happening.
 
Dec 1, 2020
33
0
30
0
Is it possible it could be a virus or does virus not drop fps after some hours of computer being on I did a virus scan and also malwarebytes but nothing came up... so do you want me to leave it running for some time then close game and send you images?
 

jay32267

Illustrious
Is it possible it could be a virus or does virus not drop fps after some hours of computer being on I did a virus scan and also malwarebytes but nothing came up... so do you want me to leave it running for some time then close game and send you images?
Usually.....when a game starts acting up after a bit of time...it's either temps or voltages....and the low voltages are usually also the result of temps.

Usually it's not software.

Usually with software...the problem happens right away and doesn't change.

This doesn't sound like your issue.

As I said....run HWInfo...minimize it....run the game four hours if you have to....to get the problem to occur. Then close the game.

Make sure HWInfo is running the whole time.

THEN....post the HWInfo pages.
 

jay32267

Illustrious
So you ran it until the problem occurred...and this is what you got afterwards?

I can't find anything out of the ordinary....and if this data is good I don't think you have a temp or a power supply problem.

If this is the case...I think the next thing I would do is power down...and reseat all the power connectors...and the cards. I think it's possible that over time....heat may be making a connector loose.

...and while you are doing this...I'd also inspect the plugs and the sockets for anything funny.

I still it's heat related....as it takes time for it to happen.
 

ASK THE COMMUNITY

Latest posts