FPS drops after few minutes of playing

Jerahya

Reputable
Jul 23, 2016
54
2
4,565
6
I'm trying to fix a unit that I built from scraps and used parts. Everything is working fine but for some reason the FPS seams to drop for about 40% or more after more or less 5 minutes of playing. I tried it on GTA V starts from 80-90fps then drops to 40-50 after couple of minutes then way less for about 30+fps after some time. Tried to run dota 2 and the game starts at 80-90fps then drops to 60+fps and spikes to 50.

The whole system is running cool even in stock cooler. GPU is at 50+C not going 60C and CPU is at 60+C not hitting 70C.

The thing that I notice is when the fps is normal GPU seams to be at 100% load and CPU sits 60-70%. When the FPS drops GPU is at 50-60% and CPU is at 90-100%. But CPU temp stays the same sitting at 60+C and clock stayed at 3.5-3.7Ghz. Check the tast manager and nothing seams to hog the CPU except for the games that I'm running. Tried other GPU and it seams to do the same so most probably not a GPU issue but I don't know where to post this thread.

The system is running with
i5 2500k
Asrock H61M-HVGS
Gskill Aegis 8GB DDR3 1600mhz running @1333mhz for the CPU
500watts Rapter PSU
Gigabyte GTX460
Other GPU that I tried GTS 250, GTX 560, GTX 750.
 

Jerahya

Reputable
Jul 23, 2016
54
2
4,565
6
Idle cpu stands at 99-90% when not running anything. I really don't see the cpu dropping its clock speed. Let me do couple of test with h aida64

update: no thermal throttling when running aida64 for more than 10 minutes. :S

update: SOLVED, I just updated the bios to 2nd latest one since the latest one gives me booting problem.
 

Jerahya

Reputable
Jul 23, 2016
54
2
4,565
6
The cpu is not close to bottlenecking the gpu. And if its a bottleneck it would start at high cpu usage instead of the gpu usage. In my case it started at high gpu usage and low cpu usage at high fps then dives at low gpu usage high cpu usage low fps on the same scene.
 

Jerahya

Reputable
Jul 23, 2016
54
2
4,565
6
Idle cpu stands at 99-90% when not running anything. I really don't see the cpu dropping its clock speed. Let me do couple of test with h aida64

update: no thermal throttling when running aida64 for more than 10 minutes. :S

update: SOLVED, I just updated the bios to 2nd latest one since the latest one gives me booting problem.
 

ASK THE COMMUNITY

TRENDING THREADS