Question FPS Drops in Horizon Zero Dawn PC.

Zuber Khan12

Honorable
Dec 20, 2014
86
6
10,535
0
Hello Community :),

I bought Horizon for PC from steam, the day i got this game, it took 45min around to optimize and i was happy with the result because i was getting 60fps on high setting, i played around 6 hour straight without any issue.

But next day when i started the game, FPS drop down from 60 to 20fps, i dont know what happened, i didnt change any setting and i did try in every settings, even in lowest i am getting same fps, i already have latest nividia driver but reinstall it (just in case).

If anyone faced same issue or anyone can help me out please share it.

I have :
AMD FX 8320 eight core.
16gb vengeance ddr3 1600mhz ram
Nividia gtx 1070 8gb.
win 10
 

madmatt30

Titan
Ambassador
If the FPS is still low at reduced graphics setting then that puts the blame firmly on the cpu.

The 8320 is old and Im surprised you ever hit 60fps with it because zero dawn is a hard game to run.

If you did you did though, have you checked cpu temps, clocks and usage??

The new game install may be entirely coincidental, something may have inadvertently happened to your cpu/cooling at roughly the same time.
 
Reactions: Zuber Khan12

Zuber Khan12

Honorable
Dec 20, 2014
86
6
10,535
0
If the FPS is still low at reduced graphics setting then that puts the blame firmly on the cpu.

The 8320 is old and Im surprised you ever hit 60fps with it because zero dawn is a hard game to run.

If you did you did though, have you checked cpu temps, clocks and usage??

The new game install may be entirely coincidental, something may have inadvertently happened to your cpu/cooling at roughly the same time.
.

To be honest i was surprised too, I never thought i would able to hit 60, i thought around 30 on medium setting would be enough. Although game compromised with my resolution its on 1280x 720.

I did upload a short video of my game play with MSI after burner you can see all details:
This is cut scene:
https://www.youtube.com/watch?v=LIIBEuK_zn8 .


this one is game play:
View: https://www.youtube.com/watch?v=ud6P5jtPsfo






Everything is working so perfectly
 

madmatt30

Titan
Ambassador
.

To be honest i was surprised too, I never thought i would able to hit 60, i thought around 30 on medium setting would be enough. Although game compromised with my resolution its on 1280x 720.

I did upload a short video of my game play with MSI after burner you can see all details:
This is cut scene:
https://www.youtube.com/watch?v=LIIBEuK_zn8 .


this one is game play:
View: https://www.youtube.com/watch?v=ud6P5jtPsfo






Everything is working so perfectly

Surprising performance for an old fx?!

Can you do the same again now that performance is reduced?

There has to be something going on with the cpu to lower it that substantially.

11gb ram used, that game is a real hog with memory!

I just downloaded it this morning but not had a chance to play it yet.

On another note you should set res back to 1080p imo.

The auto optimisation is way off if it renders 720p the optimal resolution for a gtx 1070 at medium settings.
 
Last edited:
Reactions: Zuber Khan12

Zuber Khan12

Honorable
Dec 20, 2014
86
6
10,535
0
Surprising performance for an old fx?!

Can you do the same again now that performance is reduced?

There has to be something going on with the cpu to lower it that substantially.

11gb ram used, that game is a real hog with memory!

I just downloadef it this morning but not had chance to play it yet.

On another note you should set res back to 1080p imo.

The auto optimisation is way if it renders 720p the optimal resolution for a gtx 1070 at medium settings.
Sure,
This one is the default setting in which i used to get 60pfs and 720p:

View: https://www.youtube.com/watch?v=4xzSPc-qtdk


---------------------------------------------------------------------------
This one on high setting 1080p :

View: https://www.youtube.com/watch?v=ic3rq6lqoxs


---------------------------------------------------------------------------
This one is on lowest setting on 1080p :

View: https://www.youtube.com/watch?v=1l8zGY1z4yo


--------------------------------------------------------------------------
 

madmatt30

Titan
Ambassador
So at 720p you're still limited fps wise all of a sudden??

The GPU usage is bizarre, its maxed out no matter what the res or settings.

I would not expect 97% gpu usage with a 1070 at 720p just to hit 60fps.

You literally cannot get that perfoemance back from your initital video now at all irregardless of settings or resolution??
 
Reactions: Zuber Khan12

Zuber Khan12

Honorable
Dec 20, 2014
86
6
10,535
0
So at 720p you're still limited fps wise all of a sudden??

The GPU usage is bizarre, its maxed out no matter what the res or settings.

I would not expect 97% gpu usage with a 1070 at 720p just to hit 60fps.

You literally cannot get that perfoemance back from your initital video now at all irregardless of settings or resolution??
Yes, no matter what i do, i am getting same performance, And this is what i am not getting, according to system requirements my PC is capable running this game on medium setting. and l already played this game 6 hours with 6ofps.
I dont mind playing on 30 to 40 fps which is pretty much smooth. but 20fps in every setting on 1070 is something i am not getting
 

Zuber Khan12

Honorable
Dec 20, 2014
86
6
10,535
0
So at 720p you're still limited fps wise all of a sudden??

The GPU usage is bizarre, its maxed out no matter what the res or settings.

I would not expect 97% gpu usage with a 1070 at 720p just to hit 60fps.

You literally cannot get that perfoemance back from your initital video now at all irregardless of settings or resolution??
Hey there,
I found the solution.

Well i dont know how this is possible, but when first i played this game, In which i was getting 60fps was on my 50inch Led TV through HDMI and next day i played on my 22inch Samsung monitor in which i faced that FPS drop issue.

So after doing everything, I tried on my LED TV and it worked like before, i am getting again 60fps and smooth game play, I dont know what is the reason behind it, But now i am enjoying Lol ..
 

madmatt30

Titan
Ambassador
Hey there,
I found the solution.

Well i dont know how this is possible, but when first i played this game, In which i was getting 60fps was on my 50inch Led TV through HDMI and next day i played on my 22inch Samsung monitor in which i faced that FPS drop issue.

So after doing everything, I tried on my LED TV and it worked like before, i am getting again 60fps and smooth game play, I dont know what is the reason behind it, But now i am enjoying Lol ..
Thats kind of bizarre but good news.

I had an hour on the game last night, locked at 60fps ultra settings.

Just finished the 'training' missions, I'm not getting the hate for this game at all, it looks absolutely stunning and performance is rock solid for me.
 
Reactions: Zuber Khan12

Zuber Khan12

Honorable
Dec 20, 2014
86
6
10,535
0
Thats kind of bizarre but good news.

I had an hour on the game last night, locked at 60fps ultra settings.

Just finished the 'training' missions, I'm not getting the hate for this game at all, it looks absolutely stunning and performance is rock solid for me.
Yes.. that game is beautiful, even on 1080p i am getting good 40 to 50fps. i guess my old fx8320 still powerful.
Happy gaming and thanks for your responses .. And can you please post my reply as answer so that if anyone else face this issue this can help :)
 

ASK THE COMMUNITY