Question FPS drops on primary monitor in dual monitor setup!!!

nexuslotus

Distinguished
Aug 7, 2010
63
0
18,630
0
I have dual monitor setup using 27" 144Hz Asus G-Sync gaming monitor set as primary and 27" LG 60Hz without G-Sync as secondary. Both monitors are connected to GPU using DisplayPort cables. Primary monitor is using its native resolution of 2560 x 1440 and my secondary monitor is using its native resolution of 3840 x 2160. I play various games on primary monitor with G-Sync enabled in Windowed mode and I usually have web browser up on secondary monitor for web browsing and watching Youtube using Chrome. During gaming temperature of CPU stays below 55 and temperature of GPU stays below 75 all the time.

Sometimes and not all the time, FPS drops from 144 to a range between 40-50 on my primary monitor and in addition to that it becomes extremely laggy in games so that I cannot even play the games.

After trying out various methods to replicate the problem and fix it, I'm guessing that my computer is not realizing that my gaming monitor is the primary monitor so that various system resources are being limited to be used by it and my computer believes that my secondary monitor is being used as primary.

What causes this and how do I resolve this issue? How do I manually tell my computer that gaming monitor is the primary monitor and have my computer let my primary monitor to use most of the system resources? I'm guessing it's either the OS or GPU not realizing that gaming monitor is being used as primary and limiting system resources to be used by primary monitor.

These are some of the things I have found during testing.
(1) It happens even when I load a game on my primary gaming monitor after rebooting the system and have nothing on my secondary monitor sometimes but NOT all the time.
(2) FPS drops when I click on anywhere on my secondary monitor sometimes but NOT all the time
(3) FPS goes back to 144 when I click on anywhere on my secondary monitor and then click anywhere on my primary monitor but NOT all the time
(4) When I change the selection in Windows Display Settings from "Extend these displays" to "Show only on monitor 1", my OS disables secondary monitor and FPS is restored back to 144 on my primary monitor ALL THE TIME
(5) When I unplug the cables from the secondary monitor, FPS is restored back to 144 on my primary monitor ALL THE TIME
(6) Toggling "Use Hardware Acceleration when available" in Chrome settings did not have any effect

I do not want to unplug secondary monitor from GPU and connect only 1 monitor when I game.
I do not want to disable secondary monitor from Display Settings in Windows OS.
I do not want to connect secondary monitor to motherboard instead of GPU.
I do not want to use different web browser so I did not try using IE or FireFox.

Games that I play the most is World of Warcraft and it's a very old game that does not use alot of system resources so I'm 100% sure that the cause of this problem is not from not having enough system resources from CPU, GPU, RAM and so on. I believe my computer is limiting system resources being used by primary monitor. I do not have any heavy apps running in the backgrounds and I do not use 3rd party anti-virus app. But, I use Windows Firewall and Security settings. I also do not run any heavy apps on my secondary monitor during gaming. In fact, I don't have any heavy apps that use alot of system resources in my computer besides games.

My Current Setup
CPU: i7-9700K without OC
MOBO: Asus ROG Strix Z390-I Gaming
RAM: 2x16GB @ 3200
GPU: EVGA GeForce GTX 1080 SC ACX 3.0 8GB
Storage: NVME M.2 Samsung 970 Pro 1TB
OS: Windows 10 Pro
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS