Question FPS lag on all my games with an i9-9900k + RTX 2070

R99 .

Prominent
Jan 3, 2020
110
2
585
0
Hi guys, built my system sometime last year and since day on of it being built I had constant FPS problems on all my games and I have absolutely no idea why... I played Arma 2 DayZ mod today and even on that game I get massive amount of drops and spikes on all types of graphics settings whether high or low :/

as I've had this PC for a while I've pretty much tried everything possible from what people have suggested or from what I have found from my own research but legit nothing has helped at all... if anyone has any idea what could be causing this issue or any settings that I just didnt turn off when I finished the build then please let me know because the only game I can play lag free is Valorant... not sure if its my GPU giving me problems.

Thanks in advance

https://www.userbenchmark.com/UserRun/41943131
 
Do you have CPU-Z and HWMonitor installed?

Install/run them both, and on CPU-Z, select the Bench/stress CPU tab (run it for 15 minutes, noting temps and clock speeds across all cores, and report the results...; a 9900K on a Z-390 board should maintain 4.7 GHz if cooling is adequate, and, barring any power limits/bosst duration limits. If MCE were enabled, the CPU might boost attempt to boost to 5 GHz, which might cause overheating)

WIll await your results.
 

R99 .

Prominent
Jan 3, 2020
110
2
585
0
Do you have CPU-Z and HWMonitor installed?

Install/run them both, and on CPU-Z, select the Bench/stress CPU tab (run it for 15 minutes, noting temps and clock speeds across all cores, and report the results...; a 9900K on a Z-390 board should maintain 4.7 GHz if cooling is adequate, and, barring any power limits/bosst duration limits. If MCE were enabled, the CPU might boost attempt to boost to 5 GHz, which might cause overheating)

WIll await your results.
Hi there, thanks a lot for the reply and apologies for taking so long to reply, I will do the stuff you just told me to do when I'm home later today and will post results here :)
 

R99 .

Prominent
Jan 3, 2020
110
2
585
0
Do you have CPU-Z and HWMonitor installed?

Install/run them both, and on CPU-Z, select the Bench/stress CPU tab (run it for 15 minutes, noting temps and clock speeds across all cores, and report the results...; a 9900K on a Z-390 board should maintain 4.7 GHz if cooling is adequate, and, barring any power limits/bosst duration limits. If MCE were enabled, the CPU might boost attempt to boost to 5 GHz, which might cause overheating)

WIll await your results.
Hi sorry for taking so long, I just did the test and the temps seem to be fine, maxing out at 65 on most cores but averaging like 59 to 61 at 100 percent usage, the core clock speeds keep fluxuating between 4.4ghz and 4.5, idk if thats normal or not
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts