Question FPS Stutters in every game

Aug 3, 2021
6
0
10
0
So i recently switched from a GTX 1060 6gb to an RTX 3070 and now every game i play stutters, i reinstalled windows, i reinstalled Nvidia driver, my storages are not even at half capacity, i tried every best setting i could change in windows to optimize my pc for gaming and still not working, my gpu and cpu temperature are normal, they stay at like 60c when gaming and the usage of both are normal too, none of them hit 100%, also i cant play games at low settings because its gonna lag even more, its probably caused by a cpu bottleneck but the stutters in everygame in any settings i dont think its cpu bottleneck, i really need help

Config:
CPU: Intel i7-8700
GPU: Gigabyte RTX 3070 Gaming OC
RAM: Crucial Ballistix 2x8gb 3000Mhz Dual Channel
MOBO: MSI Z390 Mpg Gaming Edge AC
PSU: Corsair RM750
SSD: 128gb
HDD: 2x1Tb
 

perrynick17

Commendable
BANNED
Dec 30, 2018
131
1
1,580
0
your graphics card is not getting all the power it needs, check and make sure cables are inserted to the graphics card power ports and at the power supply, verify that your cables are receiving power from the correct power supply out put connection
 
Aug 3, 2021
6
0
10
0
your graphics card is not getting all the power it needs, check and make sure cables are inserted to the graphics card power ports and at the power supply, verify that your cables are receiving power from the correct power supply out put connection
i checked my cables and yep, plugged the cables in the cpu connector on the psu, its working way better but still my cpu is bottlenecking in some game so i'll probably upgrade to an i9-9900k
 

perrynick17

Commendable
BANNED
Dec 30, 2018
131
1
1,580
0
do you have the CPU and GPU running off that one section of 3 connections in the bottom right it sounds like now your CPU is not getting the power it needs
 
Aug 3, 2021
6
0
10
0
do you have the CPU and GPU running off that one section of 3 connections in the bottom right it sounds like now your CPU is not getting the power it needs
Im pretty sure everything is plugged correctly now, when gaming my cpu is running at 70w and my gpu between 100w-200w with average of 150w
 

ASK THE COMMUNITY