Question Frame rate drop and/ or general slowed function

Feb 15, 2019
2
0
10
0
Hello, I've been having frame rate problem while playing Fortnite recently, in addition to general slowed computer function. Not sure if they are linked or not.

My PC..
  • Intel- Core i7-6700K 4GHz Quad-Core Processor
  • Asus- GeForce GTX 1070 8GB STRIX
  • Corsair Vengeance LED 16GB (2x8GB) DDR4-2666 Memory
  • Gigabyte- GA-Z170XP-SLI-ATX LGA1151 Motherboard
  • Samsung 850 EVO-Series 250 GB 2.5" SSD
  • Thermaltake- 750 W 80+ Gold Certified Semi-Modular Power Supply
  • Monitor BenQ 144hz
About 3 weeks ago I was able to play at 1080p Epic (Ultra) settings and consistently sit above 100 FPS at the lowest, 144 FPS most of the time with no overclocking or modifications performance wise.. Since the last two patches (not sure if this is a software issue on my end or some changes in the game causing these issues) I have experienced a considerable drop in performance and now sit anywhere from 15 FPS up to roughly 70 FPS on Epic settings with a noticeable drop anytime I encounter enemies or even walk by Tilted Towers. When I reduce my video settings to the lowest possible I only gain about 10 frames at most but still have the drops.

I did some research and did some tweaks to try and boost my performance using the NVIDIA control panel including
  • Changing Open GL Rendering to my graphics card (previously set on automatic)
  • Changed power management to maximum performance instead of optimal
This had no effect on my frame rate in game and if anything made it even worse. (Confused yet? Because I am.)

I have no experience overclocking but did some more research, downloaded MSI Afterburner and Unigine Heaven and ran some tests and found similar results to when I changed from epic to low quality settings in game. I was only able to get about 72 FPS avg on low settings even after making a few tweaks. When I re-tested on Ultra I got around 60 FPS. All CPU temps and GPU temps are surprisingly stable with minimal increase when running the Ultra tests and it seems as if my PC is not even being "pushed" or "ramping up" with the increased demand.

This led me to believe it is some software issue so I reinstalled NVIDIA drivers and still no change. Some people have reported similar issues specifically with Fortnite however I cannot test another game because I live in a rural location and rely on a limited hot spot for downloading games and updates. Regardless my general computer function has seemed to slow slightly recently as well so I'm suspicious of some software issue as the main cause. Anyone have any tips or experiencing something similar?
 

SSBrando

Distinguished
Sep 14, 2008
40
2
18,545
4
Just a shot in the dark because a friend of mine was complaining his computer was running slow the past few weeks and wanted to add more RAM (he has 16GB) and upgrade his Nvidia card. I asked him if he knew if X.M.P. was enabled in his BIOS setup. He went home, found out it was disabled and now works like it did when I first built it for him. Why it suddenly turned off I don't know. I'm assuming your memory supports X.M.P so,
In case you don't know how to get there:
Turn on your PC and to get to the BIOS keep hitting the del key
Under the M.I.T. tab I believe you'll want to select 'Advanced Frequency Settings'
Look for 'Extreme Memory Profile (X.M.P.)'
If it's disabled, change it to 'Profile1'
Make sure to hit F10 to Save and Exit
Here's your motherboard's manual if I got you lost:
https://www.gigabyte.com/Motherboard/GA-Z170XP-SLI-rev-10#support-manual
Hope that helps.
 
Reactions: Legoman86
Feb 15, 2019
2
0
10
0
Just a shot in the dark because a friend of mine was complaining his computer was running slow the past few weeks and wanted to add more RAM (he has 16GB) and upgrade his Nvidia card. I asked him if he knew if X.M.P. was enabled in his BIOS setup. He went home, found out it was disabled and now works like it did when I first built it for him. Why it suddenly turned off I don't know. I'm assuming your memory supports X.M.P so,
In case you don't know how to get there:
Turn on your PC and to get to the BIOS keep hitting the del key
Under the M.I.T. tab I believe you'll want to select 'Advanced Frequency Settings'
Look for 'Extreme Memory Profile (X.M.P.)'
If it's disabled, change it to 'Profile1'
Make sure to hit F10 to Save and Exit
Here's your motherboard's manual if I got you lost:
https://www.gigabyte.com/Motherboard/GA-Z170XP-SLI-rev-10#support-manual
Hope that helps.
Thanks for the reply! I’ll check and report what I find.
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS