Question FreeDOS Won't Run MS DOS "compatible" BIOS Update

Status
Not open for further replies.

NatoPotato390

Commendable
Feb 24, 2019
13
0
1,510
0
Been trying to update the motherboard on my old Dell Inspiron N7110, (current bios version A8) since I've been having a lot of issues booting other OS's (specifically right now ubuntu server 20)
Most recommend turning off safe boot or trying legacy/UEFI options, but this bios version has none of those 🤷‍♂️

BIOS Update is here https://www.dell.com/support/home/en-us/drivers/driversdetails?driverid=fwjtd (A13)

Site say's it's perfectly compatible with running in MS DOS so I set up a USB stick using rufus freeDOS and plopped the exe in.
Stuck it in, freeDOS loaded just fine, exe was there. Tried to run it, got "This program cannot be run in DOS mode."

Now who's fault is this, Dell's or mine? (probably dell's)

If there's any way for me to do this with freeDOS or another easy alternative please let me know, I REALLY do not want to have to hassle through reinstalling windows 7, ect.
Also if someone can tell me if I'm wasting my time and this bios update wont give me any options for turning off safe boot / UEFI please do.
 
Last edited:
Status
Not open for further replies.

ASK THE COMMUNITY