Freesync on Samsung chg90

thently

Distinguished
May 10, 2007
1,971
0
20,160
174
So I have the 49 inch Samsung monitor. I want to try out the freesync from the Nvidia 1070. i downloaded the driver for this but the OSD for the monitor says FreeSync is off and can only be turned on if AMD video card is connected. This also makes the gsync portion on the nvidia driver not show up at all. So I am guessing I will have to trick the monitor to turn on Freesync to have the driver even try to use this. I have upgraded the firmware on the monitor but this has not helped so far. So has anyone figured this out or have any ideas.

Thanks
Thent
 
Jan 16, 2019
1
0
20
1


You need to turn lag reduction off in monitor OSD and then option to turn the freesync on will show up
 

thently

Distinguished
May 10, 2007
1,971
0
20,160
174
Well it would if it was on on the monitor. As it is the gsync portion is missing I think this is because it is off on the monitor. But I can not turn it on it is greyed out. It wants to see a AMD videocard to even be able to turn it on from what I understand.

Thent
 
Jan 16, 2019
3
0
10
0
I have a CHG90 also - from what I can tell, The monitor has three options for freesync support "Off", the "Standard Engine", and the "Ultimate Engine" (I do not know the difference between standard and ultimate).

To see if your Freesync support is turned 'on' in the monitor press the power button once to bring up the menu, then toggle the power button away from you (toward the back of the monitor) to select the 'menu'. Push the power button again to open the display menu for the monitor.

You should now see the menu on the right side of the display just above the power button. There should be 5 circles across the top with various things in them. The 4th one ro the right is the status of FreeSync on your display. If it says 'On', then it is on already.

However, I have turned these things on, switched between 'standard' and 'ultimate' without success.

I also tried restarting my PC and monitor, reinstalling the drivers for the card and the monitor, and swapping to another display port on my gtx1080, but NVIDIA will not detect that the monitor has FreeSync (even though it is obviously ON and should be working).

I am going to buy the Radeon Vega VII on release next month, so this should only be a problem for me for another 20 or so days till the new AMD video card arrives which should fully support FreeSync properly.

I wish you luck with the problem though, if you happen to find a solution, please post it here so I can turn it on for the next 20 days or so ;) thanks!

(As a side note, anyone interested in a lightly used EVGA GTX 1080 SC? ;))
 
Jan 16, 2019
3
0
10
0


When FreeSync is turned on in the menu on the monitor, the option for 'lag reduction' is not available. I can turn freesync on the display to 'off' then the lag reduction option becomes available. But when freesync is turned 'on' in the monitor display, then the lag reduction option becomes greyed out and can not be selected. ( i.e. this solution does not work)
 
Jan 16, 2019
1
0
10
0
I have the same monitor but with a gtx 1080. Should bed the same setup though. I first turned on freesync on the monitor to standard engine. Then in the nvidia control panel, go to "manage 3d settings." Under vertical sync change it to adaptive and also make sure "monitor technology" says g-sync compatible. Save your settings and then the "set up g-sync" option will appear on the left hand side. Then click on that, check the "enable g-sync" box, select your monitor in step 2, then check the box in step 3. Also, I noticed if you alt+tab out of a game g-sync will stop working until you restart your game, so make sure you have the option for "enable for windowed and full screen option checked. To check if it's working in game, start your game, open the OSD on your monitor and go to information menu. you'll see your resolution and your refresh rate. When it's working you'll see the refresh rate change. mine bounces around 133 and 144.
 

thently

Distinguished
May 10, 2007
1,971
0
20,160
174
This was exactly the issue thank you. I used the answers from several posts to get everything setup but this was the one that made the freesync option not greyed out so i could setup the driver portion. Thanks allot everyone that answered.

Thent
 

ASK THE COMMUNITY

TRENDING THREADS