Question Freezing and restarting on "Automatic Repair" ?

Aug 25, 2022

I've looked through every possible post and video I can find on the "automatic repair loop" situation, but I'm having a bit of a unique take on it and can't seem to find any similar issues. This is running Windows 10 Pro.

This is a relatively new machine, built a couple months ago. It's been working fine until some point last week, where I'd gone out and returned to my pc with the blue screen error message. It restarted fine, so I thought nothing of it, until it just did it again last night. It will now get stuck in various stages of "Automatic Repair", and I can't pinpoint what exactly is going wrong now. Chipset drivers/BIOS/other drivers were all updated immediately upon building.

I can enter the BIOS and change settings around just fine. It never freezes or resets in the BIOS.

So far I have tried:
  • Removing all USB devices
  • Down to a single stick of RAM
  • Disabled "Fast Boot"
  • Attempted to boot from USB and repair or reinstall windows, which freezes.
Occasionally it will even launch straight into windows splash screen where I can log in, and then about 20 seconds later it will just freeze again. My main issue seems to be quite random, as it will freeze completely or reset back to the Asus splash screen (with the loading dots, usually right after booting up), where it freezes again.

I haven't been able to attempt half of the different options for troubleshooting the "automatic repair loop" because it will freeze or reset/freeze after a short time of trying to click through any of the options menus. I can't get into safe mode either. When booting from the USB, it will allow me to begin choosing options for "repair" or "install", however it will lock up after clicking through a few menus. I've tried to uninstall recent updates through the troubleshooting menu, but as you can probably guess by now--it freezes.

At this point I am quite lost, as it seems to get to a different place every time I restart it. I'm going to attempt to replace the main SSD with another drive with a fresh windows install and see if that does the trick, but I'd love to track down what is causing this problem to begin with.

Part of me thinks it might be a USB issue, but I'm not sure. If I boot up without any USB devices plugged in, it will get to whatever menu it feels like reaching at that given point, (automatic repair, windows login, windows install, etc.) but once I plug in a mouse or keyboard to start clicking through menus, it will freeze every time. Perhaps the boot/reinstall from USB option is not working due to this as well?

Sorry for the long post, but I wanted to provide as much detail as possible. Any assistance is greatly appreciated.


Motherboard: ASUS ROG Crosshair VIII Hero (WI-FI)
CPU: AMD Ryzen 9 5950x
RAM: G.Skill Trident Z Neo 64 GB (4 x 16 GB) DDR4-3600 CL16
SSD: Samsung 980 Pro 2 TB M.2-2280 NVME

PSU: Corsair RM 1000x
Last edited: