Question Freezing on boot screen

Apr 22, 2019
4
0
10
0
New built pc, new hardware exept for gpu and psu. Cant get to windows installation, freeze right before on the board logo screen( where you can see small circle of dots for loading). I try taking pieces in and out, try different socket for ram, plug in my old hdd(freeze on windows loading screen instead)... even change the motherboard because the geeksquad(they are BAD) told me it was defective but nothing seems to work... i need help plz
Heres the full set:
GPU:Evga Nvidia Gforce Gtx 1060
CPU:Intel core I7 8700
SSD:Samsung 860 evo m.2 500G
RAM: PNY Anarchy 16g kit(2x8g) DDR4 2400mhz
PSU:Thermaltake TR2-600NL2NH
Motherboard: TUF GAMING Z370-pro

And i just realised that the fans start and stop like 2 to 3 time before fully start
 
Last edited:

Lutfij

Titan
Moderator
Have one stick of ram populating the board, shown in the manual. You may want to see if you can power up without the discrete GPU dropped into first PCIe x16 slot. I'd also look at the PSU and ask you to swap that out. That is something I'd use as a paperweight, IMHO.
 
Apr 22, 2019
4
0
10
0
I tried with only one stick of ram in every slot possible and without gpu... still not working... but since i just bought my CPU on amazon, i sent it back and bought an other one(same one) ill see when ill have it but if it still freeze it will be psu switch time lol. Hopefully its not a compatibility probleme... just wish i dont need to change RAM...

Btw, while trying to make it work, my hdmi slot wasnt working at all(tried it with a friend). I had to use the old type of wire, Dvi i think(what i had from the start, the big white plug), to have an image
 
Last edited:

ASK THE COMMUNITY