[SOLVED] Frequent download speed drops

mumus1911

Commendable
Jun 27, 2019
8
2
1,525
1
I'll try to explain the issue as best i can.

I have a 1000 mbps download speed on paper from the isp and under optimal circumstances i get around 500-800 mbps of download speed and thats alright, however a couple of months ago the isp router started doing an odd thing.
Every couple of days download speeds slow down to 30-40 mbps and ping goes up to 50-400 ms, but upload speeds remain normal around 150-200 mbps. Another weird thing is that i have one pc in the house which always gets normal speeds, while connection slows down on any other device. I don't think this could cause it, because it gets normal speeds regardless of anything else, and other devices won't get better speeds if that pc is turned off. If I reboot the sagemcom the problem is temporarily fixed, but always comes back in a few days.

I wan't to ask for your help to find the actual issue, and maybe find a permanent fix for it. I googled it many times and i could never find any useful info on how to find the issue, the conclusion of the articles were to "reboot the router", not an actual answer. (Some articles suggested that the routers ram may get filled over time, I don't know if that is the case, since they never showed how one would check it)

Things i tried:
  • Connect to Sagemcom via ethernet cable
  • Wifi from phone
  • Wifi from laptop
  • Wired laptop to sagemcom
  • Reboot TPlink
  • Several different cables cat e5 & cat 6
Specs:
  • ISP: Telekom
  • Router(ISP): Sagemcom F@ast 3890V3 (Coax)
  • Router(wired to Sagemcom): TPlink Archer C6
  • PC motherboard(wired ethernet to tplink): Asus Z97-P
 

mumus1911

Commendable
Jun 27, 2019
8
2
1,525
1
Which router is the main router?

As I understand your description the main router is the Sagemcom. DHCP should be enabled.

The TPLink Archer appears to be intended as an Access Point. Is DHCP disabled?

Only one router should be providing DHCP IP addresses.

Check the TPLink's configuration settings.

https://www.tp-link.com/us/support/faq/1384/
Hi, thank you for the quick answer!

Your assumption is correct, sorry for not including it initially. The Sagemcom is the main router DHCP is enabled on it, Archer is the secondary in Access point(bridged if i understood the description in the router admin ui, but it is called Access point), on the Archer DHCP was set to auto changed it to off as you've instructed.

I can mark this as solved in a week or so, sooner if you could advise me on testing if the issue still persists.
 

Ralston18

Titan
Moderator
Just continue as normal - that would be the "best" test.

Try to be conscious of what all is going on with your network and especially if the speed problems re-occur.

Keep an eye on network device IPs for example: there should be no duplicates.
 
Reactions: Kevin0x1

ASK THE COMMUNITY