Question Frequently only able to connect to ipv6 sites.

Nov 11, 2019
3
0
10
0
Hello. This problem cropped up 4 days ago on my Windows 10 Desktop PC, and has been annoying me since.

The long and short of it, my computer will stop connecting to sites and programs that don't use ipv6, and only use ipv4. Facebook, Google, Youtube, and Netflix are what I tested that still work. Meanwhile, sites like Amazon, and Tomshardware fail to load, while programs like Discord don't work anymore, and Steam cannot connect online.

This happens under 3 circumstances
-The computer falls asleep and I wake it up (almost without fail this causes it)
-The computer restarts or boots up (coin flip if it happens. Haven't counted enough to tell, but it's about 50/50)
-Completely randomly (rarely, happened maybe twice)

The weird thing about this is the solution to my problem seems to change from time to time,
-Restarting the computer works rarely.
-Frequently, switching from Ethernet to Wireless, or vice versa, fixes the problem.
-Running Windows Network Diagnostics worked a few times, but most often comes with the error "Computer appears to be correctly configured but the device or resource (website.com) is not responding"
-Switching DNS away from auto-obtain to 8.8.8.8 and 8.8.4.4 has never worked, but I've seen it frequently suggested on help forms.
-Restart the router, which works sometimes, but because I room with 3 people, it's not something I want to do often.
-Running cmd as administrator and running the following commands:
  • -ipconfig /release
  • -ipconfig /flushdns
  • -ipconfig /registerdns
  • -ipconfig /renew
  • -net stop "dns client" (This one doesn't seem to work on my PC, as it says it cannot be stopped)
  • -net start "dns client" (likewise, says it's already started)
  • -netsh winsock reset all
  • -netsh int ip reset all
followed by a restart, which works maybe about a third of the time.

My computer has blue screen once with an "irql_not_less_or_equal", which then came back and solved the issue. This occurred about 2 minutes after waking it up from sleep, which I noticed that the issue cropped up. That was yesterday.

None of my other devices other than my desktop have this issue, and none of my roommates said they had it either.

Any advice on how to potentially stop this annoyance? Is this potentially a hardware issue? My PC is a custom build about 6 or 7 years old, and I'm not quite sure what parts I used.
 

ASK THE COMMUNITY

TRENDING THREADS