Question Fresh assembly, won’t post on boot. (No beep, no display)

Sep 25, 2021
5
0
10
0
Motherboard: Asus Tuf Gaming b450m plus 2.
CPU: 5600x

i had to do a bios flashback. I think it worked - it blinked slowly and then got faster and eventually the light went off. (I did it a few times, first time with just the motherboard plugged, later on I did it with cpu and cpu fan and gpu/ram attached and powered).

but then when I turn pc on, there is still no beep at all. Fans etc are running. So what should I do next?

I guess either my motherboard is faulty or cpu is broken? Is it possible that I messed up the bios flashback? But I did it a few more times still doesn’t make a difference.

I will unplug gpu/ram/cpu and do another bios flashback tomorrow to try again. but in the mean time, does anyone see any glaring problems I had?
 

kurdtnz

Respectable
Which BIOS version did you flash it to? Did you follow the instructions where it says, ''Before running the USB BIOS Flashback tool, please rename the BIOS file (TB450MG2.CAP) using BIOSRenamer?"
 
Sep 25, 2021
5
0
10
0
Which BIOS version did you flash it to? Did you follow the instructions where it says, ''Before running the USB BIOS Flashback tool, please rename the BIOS file (TB450MG2.CAP) using BIOSRenamer?"
Yeah I definitely did. I used the latest bios 3211. If I didn’t rename it wouldn’t worked I think.
 
Sep 25, 2021
5
0
10
0
Which BIOS version did you flash it to? Did you follow the instructions where it says, ''Before running the USB BIOS Flashback tool, please rename the BIOS file (TB450MG2.CAP) using BIOSRenamer?"
I just realized that my case doesn’t come with any speaker/buzzer, and I never connected the 4 pin speaker on my mobo. does anyone know where I can check if there is an integrated buzzer on the motherboard? I guess I need to buy one. It could that the buzz just didn’t go off at all.
 
Sep 25, 2021
5
0
10
0
Which BIOS version did you flash it to? Did you follow the instructions where it says, ''Before running the USB BIOS Flashback tool, please rename the BIOS file (TB450MG2.CAP) using BIOSRenamer?"
Woot,I just cleared CMOS and it is no longer no display.

now I am stuck on American megatrends screen. It just says press F1 to run setup. But my Mac wireless keyboard doesn’t seem to work correctly with it. Gonna get a standard keyboard and try again.
 
Sep 25, 2021
5
0
10
0
yep this is it. A different keyboard worked. It turns out the mac keyboard works too, but it had some special functionalities where it locks to a specific device.

looks Like people should do a CMOS reset after bios flashback to get them fully working, it doesn’t matter if cpu/gpu/rams are attached or not.
 

ASK THE COMMUNITY

TRENDING THREADS