Question Fresh build no post

Nx2

May 24, 2020
13
0
10
0
Hello guys, so I just finished up building my first pc ever and I'm not the best with it and I boot it up and the fans and RGB are on and running smoothly but no display is showing ... and the weird thing is that I tried to plug 2 different KB one with RGB backlight and one without .. the one with the RGB seems to work because the backlight RGB are on ... the other one tho is not working and I tried it on my laptop and it works fine. So I tried to smash the delete button to go to the BIOS yet no display what so ever ... my mobo doesn't have a diagnostic LED just like a normal RGB light on the side whixh tells me nothing. I checked the RAM and it's compatible I tried it with one ram, with two ram stick, on DIMM 1,3 and 2,4 yet no display what so ever. It can't be BIOS version cause the mobo says it's ryzen gen3 compatible AM4 sucket or whatever. I checked if the ram is properly installed and I checked if the CPU cable is properly connected and it was. The way I connected the front panel connecter is as follows:
(+Led)(-LED)( pwr )(fifth pin is missing)
(Nothing)(nothing)(swtch)(reserved/nothing)
All the connectors are facing down so the lapeling on the cables is facing down.
I'm connecting the pc to a tv cuz I don't have a monitor yet and I tried it on two TVs with two different HDMIs
Cpu arrow top left.
Tried connecting it to the mobo and the gpu.
What on earth is wrong !!?
Oh and the fans on the gpu are not spinning btw but maybe it's cause it's not hot ? I tried to replug the PCIs btw.

My specs:
Tuf B450m-pro gaming
Ryzen 5 3600
RX 5700xt
Vengence 16GB 3600Mhz (2×8)LPX
SSD
M.2
DEEPCOOL RGB fans with hub
PSU Corsair 650w 80+

The USBs seem to get power since they can charge my phone.

Guys please I need u to do ur magic and tell me what on earth is wrong !!
....................................
UPDATE!!!

I checked the bios version on the bar code on the mobo and it's the oldest one 0312 and for the cpu I need 1201 version ... now all the videos about updating bios tells me that I need another Ryzen cpu an old gen one to be able to update it !! I don't have that nor does the computer shops around me does !! I only have an old i5 cpu but it isn't compatible with AM4 chipset !! What can I do !!
 
Last edited:

Nx2

May 24, 2020
13
0
10
0
is that on the motherboard box? or you looking up at the website?
No it doesn't say that on the box ... but it does on the website I bought it from and I think it does on the ASUS website ... but on the box under the CPU section it only mention 2nd and 1st generation with integrated graphics card but b450 definitely support 3rd gen right ? If the problem is the bios , how to I update it ? I know nothing about these things and how can someone update bios without seeing anything on the screen !!?
 

Nx2

May 24, 2020
13
0
10
0
I have an old i5 cpu can I use it on this mobo to update the bios and then put the ryzen 5 back ? On the asus website it doesn't say that this mobo support inter cpus ! Does that mean I can't even use one to just update the bios ?
 

ASK THE COMMUNITY