[SOLVED] Fresh UEFI Build, Ram Speeds not same as legacy bios

Jul 3, 2021
3
1
15
0
Swapped over to a UEFI build of win10 with a fresh install (In case I ever use resizable bar). My Ram (4000mhz 16-19-19-39 G.SKILL TridentZ RGB Series 32GB) is no longer running at the 4000mhz profile I had it at prior to the UEFI install (on legacy bios) and it worked like that for almost the year I was running it.
I managed to get it to post at a slightly lower clock (like 3966mhz or something) and I've never fiddled with voltages or anything. I've always just used the standard XMP profile (whatever it's called for AMD now, 4 letter acronym, I can't remember).
Any idea why this is? Is there a simple fix (besides upping voltages/overclocking more)? Any help appreciated, thanks.
 

boju

Titan
Ambassador
How are you entering bios, via from Windows or pressing del on boot? Just wondered if fast boot may be enabled as I've read fast boot limits memory training. Might be the difference if fast boot is on that ya try disable it.
 
Reactions: Geige

Colif

Win 10 Master
Moderator
Unless you updated the bios, you already had a UEFI bios before, all you have done is swap boot method and ram settings aren't affected by boot method.

Did you update bios to get new mode or just reinstall windows?
Windows should have no effect on bios ram settings

XMP = DOCP on Asus boards
 
Reactions: Geige
Jul 3, 2021
3
1
15
0
Unless you updated the bios, you already had a UEFI bios before, all you have done is swap boot method and ram settings aren't affected by boot method.

Did you update bios to get new mode or just reinstall windows?
Windows should have no effect on bios ram settings

XMP = DOCP on Asus boards
All I did was re-install windows. Didn't update bios. So, yeah, I think the bios was UEFI before. When I say "Legacy bios" I meant I ran msinfo32 and it said "Bios Mode: Legacy" instead of UEFI.
That's why I'm confused. Window's should have no effect on bios so why isn't able to post with the profile I was running it on before? Something I've never seen before.

For context, on my old install I had CMS enabled and learned I wouldn't be able to use resizable bar on the new nvidia cards if I ever got one. Checked msinfo32 and bios mode confirmed it was set to legacy too (also couldn't even get it to boot with cms disabled). Did a fresh install with UEFI to keep cms disabled and that's when I ran into this problem.
To re-trace my steps:
  1. I had CMS on (and legacy bios mode)
  2. Backed up my drives, made a new usb boot drive for win10
  3. Disabled CMS, Disabled DOCP for the win10 installation (didn't know if it would cause any problems)
  4. Installed windows onto my m.2 (had to reformat gpt partition in installer)
  5. Updated drivers and everything properly
  6. Once everything was working fine and updated, I cracked open bios and re-enabled DOCP using the default profile of 4000mhz like I had it running on before
Wouldn't post, tried a couple more tries and fiddled around before it wouldn't post at anything above the 3933mhz DOCP profile I have it at right now.
 
Last edited:

Colif

Win 10 Master
Moderator
CSM - Compatibility Support Module

i don't think having xmp on during install would mess with windows. Overclocking CPU will but i don't think it does for ram.
thats not helpful now.

I see what others have to say about ram speed changing.
 
Reactions: Geige

Vic 40

Titan
Ambassador
You do have the latest bios?

Can give some extra info about the hardware this way which also gives bios version,

download hwinfo,
install and open it=click run,
close the top window which is the system summary,
in the main window at the left top click "save report",
at the bottom of the next window check "Summary for Clipboard",
after that you'll see what's in the pc,
copy by clicking "copy to clipboard" and rightclick+paste in your next respons
 
Reactions: Geige

boju

Titan
Ambassador
How are you entering bios, via from Windows or pressing del on boot? Just wondered if fast boot may be enabled as I've read fast boot limits memory training. Might be the difference if fast boot is on that ya try disable it.
 
Reactions: Geige
Jul 3, 2021
3
1
15
0
You do have the latest bios?

Can give some extra info about the hardware this way which also gives bios version,
How are you entering bios, via from Windows or pressing del on boot? Just wondered if fast boot may be enabled as I've read fast boot limits memory training. Might be the difference if fast boot is on that ya try disable it.
That fixed it. Turned off fast boot and tried booting with 4000mhz and did the usual boot loop. Turned fast boot back on, it did the boot loop again. Cut power for 3 mins and did a cold boot and it's working fine magically. Bizarre.
Thanks you three for the insanely fast help. People with more complicated issues than mine owe it to folks like you.

Also to answer your question, was using del on boot to get into bios and had fast boot on both now and before the fresh win10 install when it was working normally.
And my bios is ROG CROSSHAIR VIII HERO BIOS version 3402 from 2021-03-22 so not the most recent but still recently updated.
 
Last edited:
Reactions: Vic 40

boju

Titan
Ambassador
Oh wow did not think that would've been it. I only recently learnt about fast boot limiting the motherboard's ability to thoroughly train memory properly to save on boot time. Guess it just needs to be done once after applying memory settings, let motherboard do it's thing, and then turn on fast boot later.
 
Reactions: Geige

ASK THE COMMUNITY

TRENDING THREADS