Question Fresh Windows Install, no Ethernet or SATA drives working ?

CauyG217

Prominent
Dec 26, 2019
4
0
510
0
So, my friend installed Corsair iCUE 4 last night. He said that his computer immediately crashed and gave an error message saying something like “emergency restart”. He sent a picture of his computer on the BIOS. I told him to restart the computer. He did, and it brought him back to BIOS. After asking him to navigate around and report some results here is what we found. All 3 of his drives were showing as connected in the SATA and NVMe config menus. His NVMe WD 750 SSD that Windows 10 was installed on did not show up in the boot override or boot options menus.

Be warned. This is a bit of a long post, I have tried everything I can think of and have documented the whole process.

PART LIST: https://pcpartpicker.com/user/CauyG217/saved/kzqpBm

The following is a list of things we did to try and fix it on that night.

  1. Reset BIOS to default
  2. Disable Fast Boot
  3. Make sure Secure Boot was disabled
  4. Enable CSM
  5. He ran a drive self-test in the NVMe Configuration menu, the drive passed
After doing those and seeing no change, I told him it was probably a hardware issue and I told him to bring it to me in the morning.

Today, at my house I have now been trying at this for around 8 hours as I write this. The following are steps I did.

  1. Clear CMOS (multiple times)
  2. Unplug everything except the power cables and case fans.
  3. Try different RAM
All this had led to no change, so the next thing I did was remove his NVMe drive (it was in the Gen 3 slot on his PC) and insert it into my computer. On my computer I was able to access it and all its data. I removed the iCUE 4 software and then tried to boot to it on my system. To my surprise, this worked, and I was able to get iCUE 3 working and running fine.

When I put it back into his computer it still didn’t show up as a boot option. I then took the NVMe drive and switched it to the Gen 4 slot. This made the drive be recognized and bootable. I booted into windows to make sure it was working alright and found that the ethernet was now not working. I also found that his 2 HDDs were also not showing properly. When I opened Disk Manager, I was given the prompt to initialize the disks, but it was also showing both disks having a storage size of 2048GB. I closed the initialization window and refreshed Disk Manager to only be once again shown 2 2048TB drives.

I thought that maybe it was a driver issue caused by swapping his drive into my PC, as I have two 2TB Seagate Barracuda HDDs. I also assumed the ethernet issue was a driver issue. I went and deleted and reinstalled all the drivers on the system using a USB Wi-Fi dongle. However, this did not fix any of the issues, it caused another issue. The Wi-Fi dongle now cut out every 5 or so minutes and had to be unplugged and plugged back in to work. At this point, I went to my computer to download the latest BIOS to try and see if it would help. I went and flashed the latest BIOS (4021). After logging into windows, I saw no changes and moved on to try something else.

I took a USB drive and installed the latest Windows 10 media creation tool on it. I then plugged it into the front USB of my friend’s computer, and the drive wasn’t recognized, even after a minute or two. So, I guess added onto the list of problems is front USB connectivity. I plugged it into the top left motherboard USB slot and loaded into windows. I opened the USB and ran the windows setup. I updated the version of windows on the computer to the latest version of Windows 10. After updating it was running better and the USB Wi-Fi was working again. I tried updating the ethernet and SATA drivers again but got no change.

At this point I assumed the only fix was a fresh windows install. I then tried booting to the USB with the windows install on it but gave a black screen and never changed after about 5 minutes. I plugged it into the middle-left USB slot instead and gave it another go. This time it worked but the keyboard and mouse I had plugged into the bottom two USB slots were not working. I went and got an old PS2 keyboard and plugged it in, it worked immediately so I could install a fresh copy of windows now. Using the installer, I wiped the NVMe drive and created a new partition in it, then I installed windows on it. After a while, windows had finally installed again. I started seeing if the issues were fixed. I was very surprised when nothing had changed at all. The drives still didn’t work, ethernet didn’t work, and neither did front USB. I then started tackling these problems one by one.

Using the built-in tools to troubleshoot the ethernet said that there was no IP assigned to the computer. To try and fix the ethernet I opened a command prompt as admin and ran ipconfig to see if it knew what the local host was. It did, and it even new the name of the network, but when I tried to ping the host it lost all packets. I flushed the DNS, reset the IPv4 and IPv6, I disabled all the firewalls, and reset the network connections in the settings menu and then restarted the system. After logging in I saw no change.

I then thought maybe it was my router or modem causing the issue and restarted them both and unplugged all the ethernet cables except one which I knew worked because I used it with my PC to download the windows media creation tool. I waited until the router and modem rebooted and were working to plug the ethernet cable into the computer. At this point I checked the connection and was still getting the same message saying no IP address was assigned. At this point I gave up and moved on to the hard drives.

I opened disk manager again and this time initialized the drives. I had gotten permission to wipe them because there were only a few games on them, and they had nothing important to lose. I started to format the 2TB drive but was given an error message that windows could not format it. I tried the 1TB drive and got the same message. I tried to use the command prompt and diskpart to clean, partition, and format them, but every time I got to the format step it would fail. I switched the SATA ports around a few time and got no changes in behavior.

Finally, we have reached the present where I am out of ideas. I have tried everything in my mind to fix these issues and have no clue what to do next. I have considered that there is a motherboard or CPU problem here, but I know that I have no way of determining that at the current moment as I do not have extras of either to try. That is why I have come here to ask, does anyone have any more suggestions or ways I can further determine the cause of the issue?

EDIT: I did try booting into safe mode once and got a blue screen with the "KMODE EXCEPTION NOT HANDLED" stop code and it also said that what failed is "USBXHCI.sys"

EDIT 2: I did a second fresh install of windows but this time used the disk that came with the motherboard to install drivers and nothing changed.
 
Last edited:

ASK THE COMMUNITY