[SOLVED] Front panel connector pin short?

Jul 12, 2020
14
0
20
3
Hi there. I’m a first time builder and I started building yesterday when I ran into the old “PC won’t turn on” deal. After unplugging everything I had noticed that the one of the pins for the front panel connector pins was shorter than the others. It looks to be the pin that’s connected to the one that says “POWER_SW”. It was initially bent, so I had unbent it with some tweezers, but it’s still shorter than the others. The motherboard is an MSI Pro B450M m2 Max which is an AMD , so it has the separate panel connecter. I guess my question is do you think that this might be causing the problem, or should I keep looking? If it is, is that fixable or will I need to replace it? Thank you for any help you can give.
 

Gerald6049

Prominent
Jun 9, 2020
748
81
590
26
Hi there. I’m a first time builder and I started building yesterday when I ran into the old “PC won’t turn on” deal. After unplugging everything I had noticed that the one of the pins for the front panel connector pins was shorter than the others. It looks to be the pin that’s connected to the one that says “POWER_SW”. It was initially bent, so I had unbent it with some tweezers, but it’s still shorter than the others. The motherboard is an MSI Pro B450M m2 Max which is an AMD , so it has the separate panel connecter. I guess my question is do you think that this might be causing the problem, or should I keep looking? If it is, is that fixable or will I need to replace it? Thank you for any help you can give.
Try to turn on using screwdriver to the power_sw connector pins on motherboard.
And try minimum boot (just PSU,Mobo, RAM, CPU and graphic card), atleast they can boot to bios.
 

ASK THE COMMUNITY