• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question Front panel USB 3.0 ports do not recognize usb drives

Nexver

Reputable
Jul 15, 2017
7
0
4,510
0
Hello,

I have a Gigabyte GA-AB350M-GAMING 3 . My front panel USB 3.0 ports are giving me a hard time. They do not recognise flash drives connected to them. The devices either do not show up in Device Manager, or come up with a Device Descriptor Reuest Failed. The Drives work properly in the USB 2.0 ports and in the rear ports. All other devices connected to them( My Phone, USB to Serial Converter, headphones, etc.) work fine, but the flash drives do not.

Please Help
 
Jul 1, 2020
18
4
25
1
Few motherboards are made available with more than one USB controller. In my system, there is Intel and ASMedia drivers which should be loaded individually. Also refering to owner's manual once would help you clear your queries and doubts.
 

Nexver

Reputable
Jul 15, 2017
7
0
4,510
0
Thank you everybody for their replies.

some device might not work connected to us b 3.0 if they are usb 2.0 seams compatibilty is not on .
I have tried one USB 3.0 drive and one USB 2.0 drive.

Few motherboards are made available with more than one USB controller. In my system, there is Intel and ASMedia drivers which should be loaded individually. Also refering to owner's manual once would help you clear your queries and doubts.
Sorry, but I am not able to understand, can you please explain. Also, I have an AMD processor.
 
Jul 1, 2020
18
4
25
1
First thing you could try is by Reinstalling the driver for the host USB port. Sometimes this also fixes the issue quick. Check once and we will move further.
 

Nexver

Reputable
Jul 15, 2017
7
0
4,510
0
First thing you could try is by Reinstalling the driver for the host USB port. Sometimes this also fixes the issue quick. Check once and we will move further.
I have searched everywhere, both on Gigabyte's Website and on AMD's website, but the only drivers I could find were the Chipset Drivers. I Downloaded those but they didn't wok either. But I don't think the problem is with Windows, Even My Bios Does not recognize the USB mass Storage Devices in those Ports. They are recognized in the rear ports as well as in the front USB 2.0 ports. I have Already updated the BIOS to the latest version but to no avail. I have also tried reseating the Connector for the front USB on the Motherboard. Now I am just waiting for Gigabyte to release another BIOS update which could fix this problem.

Thank you very much for giving me your valuable time
 

Nexver

Reputable
Jul 15, 2017
7
0
4,510
0
your use 3.0 drive need to be otg compatible check the drive link https://www.amazon.ca/dp/B00RBGYG74?tag=georiot-ca-default-20&ascsubtag=tomshardware-ca-1314681072771111000-21 also did you have the app center install on board https://www.gigabyte.com/Motherboard/GA-AB350M-Gaming-3-rev-1x/support#support-dl-utility could you post a picture of the device manager open with all parts in system .
1. I have plugged in the exact same drive which you have shown, just the 32gb variant.

2. Yes, I have the gigabyte app center installed.

3. Here is the image of my device manager.
 

ASK THE COMMUNITY