Question Frustrating CSGO problem

Aug 18, 2022
2
0
10
0
Afternoon All,

I find myself here as I am really struggling and I'm being driven insane by a new but on-going issue with my PC/CSGO.

It's difficult to know where to begin as I have gone down so many different roads with this and so far nothing has sorted it. I have a powerful machine and the game has been running so smoothly up until this issue.

About 6weeks ago my game became noticably stuttery, it's difficult to describe but it's like every 3rd bullet doesn't shoot when I spray and when using a fast-firing gun such as an MP9 it's almost as if it's too much for my PC to process the high rate of fire and the whole game just stutters. Aside from this, it feel's like you're running in treacle or glue when moving in-game. Nothing is smooth/fluid, everything just feels clunky etc. It makes it almost unplayable; however there is no drop in frames/choke etc etc - I have a solid 3-400fps.

Initially I rolled back the PC to the previous windows update and this sorted the problem. A short while later it happened again and I had no option to roll back to that date. Since then it has largely stayed and it's extremely frustrating. I don't know if it's a PC issue, a monitor issue or a steam/CSGO issue. There are some weird instnaces with my monitor; it will occasionally boot in 144HZ even though its 280HZ and then it also launches the game in a lower HZ then my desktop HZ very randomly and not consistently.

Since then I have tried the following;

Updated drivers
Done all Steam/Beta suggestions as per youtube video suggestions etc
Diagnosed any connection issues with my provider of which there are non
Re-formatted/Reset windows and re-downloaded/installed everything again
After a suggestion I increased the fans on my GPU and this solved the issue for a day or 2 then it returned
Paid someone to diagnose the problem; they cleaned GPU and CPU including reapplying thermal paste - they thought it might be a heat related issue and mentioned it might be the VRMS and that I could probably do with 3 fans adding - but temps are fine?
Changed position of the PC to a cooler place, temps are fine
Changed NVidia settings in accordance with YT videos suggestions etc

Specs - i9 11900KF
Nvidia RTX 3080
32GB RAM
1TB NVMe SSD
Windows11
Liquid Airflow
750 PSU

Monitor - ASUS TUF Gaming VG279QM / 280hz

I would really appreciate any help at all.

Thank you in advance
 
Aug 18, 2022
2
0
10
0
Afternoon All,

I find myself here as I am really struggling and I'm being driven insane by a new but on-going issue with my PC/CSGO.

It's difficult to know where to begin as I have gone down so many different roads with this and so far nothing has sorted it. I have a powerful machine and the game has been running so smoothly up until this issue.

About 6weeks ago my game became noticably stuttery, it's difficult to describe but it's like every 3rd bullet doesn't shoot when I spray and when using a fast-firing gun such as an MP9 it's almost as if it's too much for my PC to process the high rate of fire and the whole game just stutters. Aside from this, it feel's like you're running in treacle or glue when moving in-game. Nothing is smooth/fluid, everything just feels clunky etc. It makes it almost unplayable; however there is no drop in frames/choke etc etc - I have a solid 3-400fps.

Initially I rolled back the PC to the previous windows update and this sorted the problem. A short while later it happened again and I had no option to roll back to that date. Since then it has largely stayed and it's extremely frustrating. I don't know if it's a PC issue, a monitor issue or a steam/CSGO issue. There are some weird instnaces with my monitor; it will occasionally boot in 144HZ even though its 280HZ and then it also launches the game in a lower HZ then my desktop HZ very randomly and not consistently.

Since then I have tried the following;

Updated drivers
Done all Steam/Beta suggestions as per youtube video suggestions etc
Diagnosed any connection issues with my provider of which there are non
Re-formatted/Reset windows and re-downloaded/installed everything again
After a suggestion I increased the fans on my GPU and this solved the issue for a day or 2 then it returned
Paid someone to diagnose the problem; they cleaned GPU and CPU including reapplying thermal paste - they thought it might be a heat related issue and mentioned it might be the VRMS and that I could probably do with 3 fans adding - but temps are fine?
Changed position of the PC to a cooler place, temps are fine
Changed NVidia settings in accordance with YT videos suggestions etc

Specs - i9 11900KF
Nvidia RTX 3080
32GB RAM
1TB NVMe SSD
Windows11
Liquid Airflow
750 PSU

Monitor - ASUS TUF Gaming VG279QM / 280hz

I would really appreciate any help at all.

Thank you in advance
Thanks for coming back to me, Liquid Airflow is the built in system in the case I believe

MOBO = Z490-A PRO
Not sure on PSU - tried looking but it's well hidden in casing
https://www.amazon.co.uk/gp/product/B077VMMFVY/ref=ppx_yo_dt_b_asin_title_o03_s00?ie=UTF8&th=1 - that's the PC
 

logainofhades

Titan
Moderator
Cyberpower is known for using poor quality power supplies. I would not be the least surprised if that is the issue. RTX 30 series needs a high quality unit, due to power spikes they produce. Low quality units don't handle this well.
 

ASK THE COMMUNITY

TRENDING THREADS