FX 6800 Checksum error after Bios upgrade


May 21, 2008
I read all the posts on this site and found that some of you were successful in resolving the checksum error
Can you please tell me what you did to fix the checksum error after upgrading the bios for the FX6800-01?
I tried almost everything, I think]



Apr 2, 2009

Not sure if you have solved your problem, but from my experience you will need to reinstall the bios flash again, and do not use the AFUWIN utility it is part of the reason you have the check some error.

So go through the system tray make sure all programs are either closed or stopped short of the safely remove hardware, disconnect from the network line and goto the start orb at the bottom left corner on the task bar then type run into the search and browse to the flash folder and flash it again. This mostly comes from Renegade's steps, but don't follow the steps for AFUWIN, I tried it twice on a new system of the FX6800 and it gave the check sum error but let me boot up still.

I think that will help otherwise, please check this thread for more info...


The key to a successful BIOS Update and getting rid of the error is as follows:

- 1) Make sure you Login using an Administrator Account
- 2) Control Panel > User Accounts - Disable UAC (Temporarily)
- 3) Temporarily Disable your Anti-Virus Program
- 4) Make sure no other programs are running
- 5) Make sure all five files from the BIOS_842P161G file have been extracted to the same directory
- 6) Use Start > Run (Folder containing Bios Files) Select the file flash.bat > OK

If you can't see the file extensions, then you need to do this:

Control Panel > Folder Options > View tab > Scroll down to Hidden files and folders

- Select "Show hidden files and folders"

- The next two items should be selected also.

You should be able to see the file extensions now.


The file flash.bat is nothing more than a DOS Batch file which contains commands for running the AFUWIN.EXE file to update the BIOS. In the other thread, I had included instructions for both methods of updating the BIOS using the Batch file or running the AFUWIN utility in Windows mode. At the time, I hadn't identified the problem others were having with trying to update their BIOS yet.

On my own system, I usually keep UAC disabled on my personal system as both my Network and all my systems are completely locked down tight and well protected. So it hadn't occurred to me that UAC was the culprit here.

Although I do not recommend keeping UAC disabled all the time or using an Administrator account as your default Login.

The best practice for most people is to use a Limited User Account except when they need to install something or run any updates.

Similar threads