[SOLVED] G-sync issue? Desktop 170hz, game 60hz?

Zoladex

Distinguished
Apr 11, 2013
103
0
18,690
1
Hi
Just installed a new monitor, M27Q, and have been setting it up with help of forums. Seems a little fiddlely!

Im not sure if i have it running right or my GPU is simply not running high enough FPS in the game. Im playing Ghost Recon Future Soldier (i have quite a big backlog to catch up on!). The game seems locked at 60FPS, but when i minimize to desktop that runs at 170Hz.

I have the following settings:
-Windows refresh rate to 170hz, checked also in nvidia control panel.
-G Sync enabled box ticked in control panel
-Control panel Monitor Technology set to G-Sync Compatible.
-Control panel V Sync set to on (this was switched on after reading BlurBusters's thread, randomly fixed a mouse polling rate bug while i was there too!)
-Rivatuner frame rate limit set to 166hz
-and lastly the monitor FreeSync Premium set to 'On'

Any thoughts why it has popped back to 60hz? I did see a video where monitor refresh rate and game FPS dont always match, for what ever reason? ha. I have both riva and monitor frame counters running and they are matching.

Yesterday, i noticed the game is quite graphically intense and i was getting 50-60fps at 99% GPU, with less demanding areas at 90-100FPS. That was only using the monitor freesync 'On', where i was getting pretty bad screen tearing. Thus i looked into how to set g-sync correctly and set the above settings, but has now locked the frame rate to 60.

I was thinking g-sync might lock to certain FPS, 60, 120,144,240, ect. So i tried lowering the graphics, but the only change was to GPU usage now at 30%...

Head scratching now :s
 
Last edited:

Zoladex

Distinguished
Apr 11, 2013
103
0
18,690
1
ooo, awesome website. Highlights all the quirks of games :) Added to bookmarks thanks!

Oops, didnt even think it could be game issue! reason why shouldnt trouble shoot pass midnight... haha
I couldnt get the game to run higher than 60fps in the end but i did fix a few other issues with it. The SpecialK file would not create the ini file, either using x32 or x64 versions. But im happy now its running smooth and its me thats crazy and not g-sync xD.
Cheers for the pointer!
 

ASK THE COMMUNITY

TRENDING THREADS