G31M GS R2.0 : No boot, or no display

tom120934

Distinguished
Jan 27, 2012
1
0
18,510
Hello,

I just received my brand new Asrock mainboard, µATX to get into a HTPC.

I have two PSU by my side, both working fine with another mainboard. First PSU (Fortron BlueStorm 500W) can't get the ASRock to boot. Second PSU (DELL 500W, no precise reference) can turn it on, but no display : either on integrated VGA or a PCI-E card (I tried two differents, both are working fine with another mainboard)

System spec :
ASROCK G31M GS R2.0, brand new.
CPU E6850, successfully tested with my previous mainboard (ASUS P5W DH)
DDRII, 2GB, 6400 (also successfully tested)

The weird things :
- An USB keyboard doesn't light up. Numlock / scrollock / caplock doesn't work.
- But a PS2 keyboard turns on 3 leds for less than a second, then they're off. Numlock / scrollock / caplock doesn't work.
- No sound on speaker, but error code I try to boot without RAM.

I tried to reset CMOS, including resetting it after getting the PCI-E video adapter removed. No luck.

My 2 questions :
- Why a decent and functionnal PSU can't get it to boot ?
- Why there is no video ?
 

Muawia Elzubair

Commendable
Mar 20, 2016
1
0
1,510
I have motherboard G31 , it give me error code D455 by motherboard tester.
what this code meaing (D455)??????
please help me very quickly?????