Question G533 Headset microphone mutes itself ?

Sephi_Toderas

Distinguished
Nov 14, 2014
122
1
18,695
2
Hey guys

My G533 is going crazy. Every time I have a call on Discord or ZOOM, the mike just mutes itself after 2-3 minutes. I cannot get it to work except if I restart ZOOM, but for Discord it will only work if I restart the PC.

Logitech support is hopeless, they were not able to help.

Any tips please?
 

Ralston18

Titan
Moderator
Has the headset mic always muted itself or did the problem just start?

This (from Logitech's website):

"An easy-to-reach volume control roller and mic mute button on the left earcup makes it simple to adjust your audio settings on the fly. For fine tuned settings, Logitech G HUB lets you set equalizer, surround sound, sidetone, and microphone levels on a per-game basis. You can even reprogram the mute button and use as a G-key to many function, like “play/pause” to start/stop your media, or any complex macros.

Are you using G Hub?

Just FYI and reference purposes:

https://support.logi.com/hc/en-us/articles/360025298133

First double check all current configuration settings.

Failing that I would proceed with manually downloading the applicable drivers and software.

Reinstall and reconfigure.
 

Sephi_Toderas

Distinguished
Nov 14, 2014
122
1
18,695
2
Has the headset mic always muted itself or did the problem just start?

This (from Logitech's website):

"An easy-to-reach volume control roller and mic mute button on the left earcup makes it simple to adjust your audio settings on the fly. For fine tuned settings, Logitech G HUB lets you set equalizer, surround sound, sidetone, and microphone levels on a per-game basis. You can even reprogram the mute button and use as a G-key to many function, like “play/pause” to start/stop your media, or any complex macros.

Are you using G Hub?

Just FYI and reference purposes:

https://support.logi.com/hc/en-us/articles/360025298133

First double check all current configuration settings.

Failing that I would proceed with manually downloading the applicable drivers and software.

Reinstall and reconfigure.
Gonna be honest, seems that when GHub is not installed, this problem is away. But I need GHub for special settings :(
 

Ralston18

Titan
Moderator
Personally I have had problems with Logitech G Hub and no longer use it.

What special settings do you need?

Perhaps there are other ways to address your requirements.

Quite likely there are others who have or had the same issue....
 
Nov 30, 2021
1
0
10
0
I have the same issue. You dont need to restart your computer however. If you bring up the sound settings, then scroll down to your mic and click on the properties. There is a checkbox there that allows you to disable and re-enable the mic which will get it working. Hope Logitech can fix this soon.
 

Sephi_Toderas

Distinguished
Nov 14, 2014
122
1
18,695
2
Personally I have had problems with Logitech G Hub and no longer use it.

What special settings do you need?

Perhaps there are other ways to address your requirements.

Quite likely there are others who have or had the same issue....
Visuals, levels, DPI, all that is saved there. I didn't find a workaround. But I guess until it's fixed, I can live without it.
 

Sephi_Toderas

Distinguished
Nov 14, 2014
122
1
18,695
2
I have the same issue. You dont need to restart your computer however. If you bring up the sound settings, then scroll down to your mic and click on the properties. There is a checkbox there that allows you to disable and re-enable the mic which will get it working. Hope Logitech can fix this soon.
Thank you, I will definitely try that.
 

stickas

Distinguished
Jan 23, 2013
98
0
18,630
0
For some reason my post was deleted with a reasoning as "hijacking". Maybe the language barrier was playing a game but I meant to help. Now I'm not digging. I wanted to have it tested before I write.

I got support from logitech and it was an update on their software. We couldn't find a working solution and they prompted me to install an older version of the LGHUB, which I did after uninstalling. Didn't work. But after I updated that version to the current one, everything was fine. Unticked the auto updates and I'm still good to go.
 

ASK THE COMMUNITY