Ga z77x d3h does not post


Nov 18, 2012
I have just finished building my computer yesterday, the build consists of the following:
Intel Core i5 3570K
Gigabyte GA-Z77X-D3H
4 GB of RAM
Crucial M4 128GB SSD
Rosewill 650W Capstone PSU
1TB Seagate HDD
CM Hyper 212 Evo

The first time I powered on the machine, it began making some noise (mainly due to the fans) and after about 5 seconds it shut down, a second later - it reboots.
This process continued on and on until I unplugged the PSU from the socket of course or hit the switch on PSU.
After careful inspection of the PSU, I realized that it was making unusual chattering noises - as if the fan in the unit was hitting against something while it was spinning.
This specific issue was intermittent, as sometimes it wouldn't make this noise but most of the time it did.

I immediately gave Rosewill a call and explained to them my problem; they told me that it was definitely a defective unit so I agreed to RMA it and get my refund.

In addition, only once did I get the system to remain on longer than 5 seconds (with 1 DIMM) and when I hooked up my monitor to the back of the onboard graphics adapter, I was greeted by a nasty BSOD. This time the PSU was still making the noises but at least it managed to pull through. I restarted the computer and it successfully posted!
I decided to check the status of my hardware within the 3DBIOS and everything seemed to be working and recognized. But when I tried to do a cold boot, BAM! We're back to where we started. :pfff:

A few moments later, I decided to experiment. I took my old computer and plugged in the newly purchased 650W.
The motherboard light went on, indicating that the system is receiving power.
But once I hit the switch, I could hear no beeps, just the rattling sound of that godforsaken power supply. However the power supply remained on which was a bit confusing for me.

So at this point, I am stuck with a case - rid of it's power supply. I have no idea whether both/either the motherboard and PSU are the culprits in this perplexing situation.
I understand that hardware, especially the motherboard is prone to electrostatic discharge and I'm afraid that I may have caused this problem while I was assembling various components including the heat sink the motherboard screws.
I tried almost everything - piece by piece removal of hardware, swapping RAM, clearing CMOS, etc...

What should I do? Should I refund the board too? Is there a special way of knowing whether your board is dead?
most times with new build people forget the 4/8 pin atx power plug or both power plugs on the video card. or they forget to use the standoffs or use the wrong screws on the stand offs and short the mb out in the case or the i\o shield fingers are shorting the mb out. i would take the mb out of the case and place it ontop of the mb box on top of the mb bag. with just the onboard video chipset and a power supply see if the mb posts. if it does then there a short issue. if not try one stick of ram and put it in one ram slot and walk the ram and see if the issue happens with all 4 slots. if it does. power off the system and check for bent pins under the cpu or a cpu seating issue. make sure you have a know good power supply.