Game FPS drops with micro-stutter

Exteez

Reputable
Jan 26, 2015
47
0
4,530
0
Hi, sorry for the long read. I have micro-stutter along side FPS drops in all games. The fps doesn't drop by more than around 20. I experience a micro-stutter with each FPS drop. Less intensive games have less stutter and fps drops. Highly intensive games have much more fps drops and stutter.

What I tried(and prob more):



    Disabling gamebar and a lot of crap in windows 10 settings.
    disabling diagtrack service.
    disabling any background programs.
    formatted PC 3 times(all drivers etc.)
    Capping fps with vsync or an external program - Whenever I cap my fps it still drops under the cap. When I have 180fps, it drops by like 20. If I cap it at 144 fps, it still drops by like 15 and stutters. Capping it at 100, still drops to like 90/95 and the stutter is there.
    Changing CPU, Motherboard, Disk, RAM, GPU, Power supply(not the cables), thermal paste.
    All temperatures are perfect - 60c while gaming max on cpu and gpu.
    Change Nvidia settings/windows to high performance/max performance
    Tried Nvidia Control Panel settings, like vsync, pre-rendered frames 1 and 4. PhysX CPU and GPU and AUTO.
    Changed Monitors/cable to monitor
    Changed power cable to PSU
    Changed windows pagefile to auto. I've then set it to 2000mb, and my stuff was crashing because out of memory. I've now set it to 16gb pagefile. In result all the settings didn't help.




I can monitor the frametime and framerate in MSI afterburner. The graph clearly shows every time I get an fps drop the framtime has a massive spike and that causes the stutters. The only thing that helps me is turning on vsync adaptive (half refresh) which caps the fps at 72. Then I don't have barely any stuttering. This seems to eliminate a lot of the stutters, but with the rig I have don't want to play a game at 72 fps when I can run it at 200.

I have recorded a video using my phone with the stutter. On here you can't see it as much because of the bad camera and not actually playing the game. Look at the micro stutter at 0:47/0:48 on the stairs, keep replaying to see because like I said it's not as noticable on the video. Another stutter can be seen at 1:40.

Link: https://www.youtube.com/watch?v=x6aERNKL7Tc

I was wondering if anyone could have any idea? I'm literally lost and been at this for months. I replaced so many parts without luck.... I am seriously willing to pay someone who would find a working solution for me, and I will...

Thank you for any answers in advance!


My specs:

CPU: i7 8700k @ 3.7 Ghz (4.4ghz turbo)
Motherboard: MSI Gaming PLUS Z370
Cooler: Liquid Cooler Kraken X62
RAM: 2x8 GB DDR4 Vengeance 3200Mhz
GPU: GTX 1080Ti
Case: NZXT S340
PSU: EVGA G2 750 W
Storage: Samsung Evo 840 - 120GB (OS)
Samsung Evo 850 - 500GB
OS: Windows 10 home official 64-bit
Display: Benq xl2411 144hz 1080p




 

cherry blossoms

Reputable
Apr 13, 2016
730
33
5,390
157
You stated in a generalized way "disabled gamebar and a lot of window crap", so if the following covers some of the items you have already done, please ignore those bits you have already done but not specifically stated
.
Try disabling hyperthreading: yes, this sucks, but def helps with smoothness in some things here for me on an 8700k (like MadVR).

Some things to try to reduce CPU usage:

Reinstall your Nvidia drivers with only the graphics driver, PhysX, and (if needed) the HDMI sound. Do NOT install GeForce Experience. It's supposed to be able to override your settings for "optimized" ones, but optimized on their test hardware, not your hardware. This item also scans your drive for said games, taking up resources. This will also get rid of one source of background video recording. Do not install the 3D driver stuff unless you are specifically using it (like for Oculus Rift or similar)

Go into advanced power settings, set performance mode. Use the advanced properties to further set CPU min/Max states to 100%, and disable PCIe link state power management.

Disable Cloud saves and Synchronization in your Gaming Clients (Steam, Origin, Uplay, etc)

Disable OneDrive if you can live with that.

Turn off storage sense

Go to your settings tab if you haven't already and look at all options under all headers. Turn off functions you don't need.

Delivery Optimization is usually on. Seems to treat your PC as a torrent source for Win updates. Turn it off.

Some people have reported success with using Utimate Windows Tweaker using the "Security and Privacy" section, then the "Privacy" tab settings. I prefer a more granular approach but ymmv.

Services to consider disabling: (Some telemetry related, ymmv depending on your particular usage scenarios)

Anything Adobe depending on usage or setting to manual
NVidia telemetry (using autoruns is helpful here also)
Connected User Experiences
Delivery Optimization
dmwappushsvc
DNSClient (esp if running a large HOSTS file. If disabled, will disable Edge and probably the store as well)
Geolocation Service
Microsoft (R) Diagnostics Hub
Microsoft App-V Client
Net Tcp Port Sharing Service
Program Compatibility Assistant
Remote Registry
Routing and Remote Access
Shared PC account management
Smart Card
Superfetch (if using an SSD)
User Experience Virtualization
Windows Biometric Service
Windows Search (big hog that runs in the background)

Use Autoruns from Microsofts Sysinternal Utilities to see what is being autostarted. Many autostart items will NOT be listed conventionally in Startup. See what is being started up and what items specific to your system might be dumpable.

Disable Live tiles that you don't need.
Disable Background functionality for Apps that you don't need or Don't need them doing that.

Turn PreFetch off: (Requires going into the registry)

How invasive is your Antivirus? Many functions you can turn off in "helpful" all in one suites. YMMV of course depending on your usage habits. I run Avast for instance, but ONLY run the Web and File Shield because of my browsing habits/computer usage. Everything you don't need is background churn.

Using a program like W10Privacy to start turning off telemetry churn that windows only gives you SOME options available to turn it off. Programs such as these help so you don't have to go hunting a bunch of stuff in Group Policy Editor or dig in the registry.
Read the choices it offers though, some items you may want to keep on, even among the green items in W10Privacy. Run this one in Admin mode, and give it a bit to present the interface (it scans throughout the system 1st to find current settings before giving you the tweak menus) It only seems like it's locked up at first.

Not sure if it is the program you are using, but you can try Nvidia Profile Inspector to set limits either globally, on on a per title basis for things like frame rate limiting, etc. Settings best for one game may not be the best for another. Afterburner is nice, but overhead as well.
Settings created in NVidia Profile Inspector need to be reentered after every driver update btw.

 

Exteez

Reputable
Jan 26, 2015
47
0
4,530
0
Thank you for such a long answer! Things I did:

Turned delivery optimmisation off
Disabled many services from the list.

However, I couldn't disable DNS Client, all options to stop/disable service were greyed out.
The following services were missing:
Microsoft App-V Client
User Experience Virtualization

Could you expand on that:
"Disable Live tiles that you don't need.
Disable Background functionality for Apps that you don't need or Don't need them doing that."

I tried running without my antivirus installed at all, with only windows defender running. Didn't help. My antivirus is bitdefender.

I am was using in game settings to limit my fps, or RivaTunerStatisticServer. I will try the nvidia inspector. I will try the W10Privacy and Microsofts Sysinternal utilities. Could you maybe provide a link to those so I don't get the wrong one or download from a dodgy site.

Thanks so much again. I will get back to you to let you know once I do the rest of the things.
 

cherry blossoms

Reputable
Apr 13, 2016
730
33
5,390
157
For NVidiaProfileInspector, the 2.1.3.10 version appears to be available at softpedia, the author's official appvoyeur link appears to be down.
Please note, select the V2 link, not the V1 link

https://www.softpedia.com/get/System/System-Info/NVIDIA-Inspector.shtml

For Autoruns, the official Microsoft page is:

https://docs.microsoft.com/en-us/sysinternals/downloads/autoruns

For W10Privacy, the official page is:

https://www.winprivacy.de/english-home/

Of note Exteez, is also that regardless of AVERAGE frame rates, you need to take into account frame times as well. If using Vsync, you will need to have a frame ready every 6.9ms to have a smooth 144Hz display (without adaptive sync). If you miss that 6.9ms window, your display has to wait ANOTHER 6.9ms until you can display the next frame, this may appear as stuttering to you depending on your sensitivity. With V-sync off, you will start dumping whatever is in the framebuffer to the display every 6.9ms, updated or not. Either may give you a feeling of stuttering depending on your sensitivity to that.
 

Exteez

Reputable
Jan 26, 2015
47
0
4,530
0


I do monitor frame time. and yes every time there is an fps drop the frame time spikes and theres a stutter. However, it does not matter whether I use vsync or not, the results are the same.
 
if you changed all hardware and clean installed the os, this might be a case where you may need older nvidia drivers that don't cause stuttering.

also, set your pagefile on a different drive if you can, not the system/boot drive, and let it be auto. you may still have some bad hardware yet, just because you change it out doesn't mean the new stuff doesn't have issues. you need to slow down and start testing out each piece.

Memtest86 the RAM for a super long time to rule it out, test the system with stress tests and OCCT which is free and can stress well, the psu as well. got to find out whether it 's software config or hardware.
 

Exteez

Reputable
Jan 26, 2015
47
0
4,530
0


I've already done the memtests for all the stuff I've had before and it showed 0 errors. There is no way this is a hardware problem just to make it clear.

I will set the pagefile to my games drive from the OS drive though as you suggested
 

Exteez

Reputable
Jan 26, 2015
47
0
4,530
0


The W10Privacy is confusing as hell, same as the autorun program, I don't know what to switch off. In W10privacy all the telemetry seems not to be blocked. Should I block them all? The rules are all similar like: "block microsoft servers, to which telemtry data will be sent, through the HOSTS file". <- This one is red, should I block it?

Same as the stuff in "tasks" it says its the telemetry stuff but some is in red, idk if I should switch it off?
 

Exteez

Reputable
Jan 26, 2015
47
0
4,530
0


3 times

@cherry blossoms - Could you tell me what should I disable in W10Privacy and autorun? There are so many things I've disabled, literally tens of things, but I'm not sure about some stuff. Could you tell me the most important things to disable? Thank you!
 

Exteez

Reputable
Jan 26, 2015
47
0
4,530
0
I did all those things and capped my fps with nvidia inspector. I capped it to 140 and it capped it to 130 for some reason. It didn't help with vsync off and vsync on. I'm lost now, really.
 

cherry blossoms

Reputable
Apr 13, 2016
730
33
5,390
157
Hello Xteez, I'll try to put up some screencaps when I have time for W10 privacy settings. Autoruns (like w10privacy), aren't automated tools. They allow you alot of options, but you have to research what tasks you are changing with them. Tasks/services that are disposable to me may be utterly required for your usage scenarios.

You may never get perfectly smooth 144hz. While mainly closer to the higher end of frame rates than the lower, vdeo I have seen on BLOPS 4 play seem to indicate radical swings in framerate / frame times from the 60's to the 200 range with 8700k and 1080ti., one such example:

https://www.youtube.com/watch?v=iR_6g4VD2Y4&t=118s.

Not sure why capping to lower rates. If less than your native any v-snc will have stutter. Your monitor is advertised as a 144 H panel, should be set to that.

For sync type, setting adaptive in the control panel will allow automatic v-sync when frame rates are above required rates, and disables V-sync when below.

Also to confirm that your 1080 Ti supports DVI-D since that standard is deprecated and therefore not all cards support it. Your monitor only does true 144hz over DVI-D, not HDMI if you are using HDMI
 

Exteez

Reputable
Jan 26, 2015
47
0
4,530
0


Okay thank you very much! Yes I realise that.. but I just want a stutter free gameplay even if I disable some shit that I use, I can enable it back later. Just want a game without stutter! I'll do what it takes....

I changed it just for a minute to 120hz to see if it would change anythinng. Now it's back at 144hz.
Yes I've changed it do adaptive now that you've said but I've tried it before and didn't get positive results. Also yes, it does support dvi-d and that's what I'm using. I've tried different monitors with different cables anyway.

I'll be keeping and eye out on this thread. I really hope you can finally help me, you seem to know what's going on. If you sort this for me I can pay you via paypal for this for your troubles. Waiting patiently!

Also, on the video I don't see the guy having stutter like me, the fps drops but his frametime is kept steady and doesn't spike to the sky like minne
 

Exteez

Reputable
Jan 26, 2015
47
0
4,530
0
Something to add is that I found a guy with a very similar problem and almost identical rig to mine. This was his response, and he didn't sort out his problem.

"Thank you for the reply.

Well, we're in the same boat with the same HW. Your specs are almost 1:1 equal to my. Also, you've described pretty the same scenario of games issues as I've. There's something global causing performance problems, like broken Windows/NVIDIA drivers root code, or games (what I really hope to finally figure out with 100% accuracy).

But, it's also possible that high-demand games're not the culprit here (except of PUBG) while other low-demand games run great on our rigs. "Light" games (CS:GO, LOL, OW, etc.) can run smooth because of weak load on the hardware (especially GPU & CPU) and that can be the reason why there're no issues with them. You wrote about a "magic" trick with adaptive VSync enabled (72 FPS on 144 Hz monitor) which helps eliminate stuttering. That's also because of lower load on the GPU and CPU respectively.

Hence, we can assume that the HW can't deal with a full load (coming from high-demand games) and this HW weakness causes stuttering.

The same in my case, RTSS FPS lock helps me to reduce (<140 FPS for PUBG) and completely eliminate stuttering (<150 FPS for GTA 5). With unlimited FPS all high-demand games run creepy with all the possible performance issues.

In conclusion, I can say that the only one working "tweak" for me is FPS lock/cap. I can't find any other valuable workarounds to solve this irritating performance misalignment.


But if you will look for the same threads with the same issues on the same rigs you'll be really impressed how common is stuttering nowadays.

It's not unique and, as I said before, there must be something global."

However, fps locking does work for him but not me! :( why :(

Edit; So I've downloaded windows tweaker and it says I have windows 10 home verion 1803, but it says its 8.1 windows experience index, whats up what that?
 

Exteez

Reputable
Jan 26, 2015
47
0
4,530
0
Yeah I am pretty sure that when I turn the computer on and go into a game I don't get stutter for like 2 mins and then it starts.
 

Lekro44

Reputable
Oct 28, 2015
78
0
4,660
5
I had a similar problem and what fixed it for me was changing the DVI-HDMI cable to HDMI-HDMI. The DVI end was at the GPU, HDMI at the monitor. Pure HDMI-HDMI and I get no stutters. This stutter persisted through clean reinstalls too.

If this doesn't apply to you, ignore.
 

Exteez

Reputable
Jan 26, 2015
47
0
4,530
0


I would love it to be that simple! I've tried 3 different monitors with 3 different cables, yet no results. I use a DVI-D to DVI-D atm. But also tried HDMI to HDMI. Thanks anyway!
 

Lekro44

Reputable
Oct 28, 2015
78
0
4,660
5
Other things I did was setting the BCLK to auto with my OC rather than 100 fixed and disabling Dynamic Storage Accelerator in the UEFI. I did these in addition to the HDMI-HDMI cable swap and I'm not sure which one of these fixed it honestly, but for sure I won't change any of them ever. By the way the power management options (both in NVIDIA CPL and Windows) I got recommended never made any difference in performance for me, so now I left everything on default, even the Windows 10 Game Bar.

I'm sorry that you have this problem, I was investigating the stuttering myself for 1+ months and it was an extremely annoying and inconvenient procedure. I hope you suddenly stumble upon the fix like me.
 

Exteez

Reputable
Jan 26, 2015
47
0
4,530
0


I'll try disabling that accelerator and might format my pc for the 4th fking time and just leave everything as it is and try the game.. I've already tried that but disabled a lot of the things in windows, but how would that cause anything idk.

Edit: The acceleration thing is not anywhere in my bios settings unfortunately, and anyway I don't think doing this would do anything since its my second motherboard. So frustrating. Anyone please help me find a solution!
 

Exteez

Reputable
Jan 26, 2015
47
0
4,530
0
Well I guess nobody has an answer anywhere. Great to live with stutter after paying thousands for my PC. GG! PC MASTER RACE GO!
 

Lekro44

Reputable
Oct 28, 2015
78
0
4,660
5
Switching to borderless windowed mode? Have you tried that? I recall the stutter was behaving differently for me. I also turned on windows 10 game mode for all my games (serious), vsync, triple buffering and in games that support it (like overwatch), reduce buffering.
 

ASK THE COMMUNITY

TRENDING THREADS