Question Game freezes on a gaming laptop (With clip)

Aug 8, 2019
8
0
10
0
First of all hello and apologies if I posted in the wrong section.

I recently got an HP Omen 15 - ce0xx

Specs include: 7th gen i7 7700HQ, GTX 1060 Max-Q 6gigs, 16 gigs of RAM

While playing some of the heavy games, I get a huge "freeze" like this:

View: https://youtu.be/23aBiv1ZDCQ


I'd very much appreciate any help regarding this. Thanks you.
 

Fix_that_Glitch

Notable
Mar 31, 2019
1,425
112
940
32
So that is a loading a new area lag. What kind of hd are you using, hd-ssd? Can you post up a picture of your Nvidia 3d settings? You can try turning down certain settings in game to allow the change scenes to load faster. What power setting are you using in windows? ie, balanced, high performance?
 
Reactions: DizzasTeR
Aug 8, 2019
8
0
10
0
So that is a loading a new area lag. What kind of hd are you using, hd-ssd? Can you post up a picture of your Nvidia 3d settings? You can try turning down certain settings in game to allow the change scenes to load faster. What power setting are you using in windows? ie, balanced, high performance?
Yes everything is set to high performance mode, I tweaked my nVidia panel to 'Max performance' and stuff, Power plan is also set to High Performance and I always play with AC plugged in. I also tried moving the game to SSD that I have but I didn't really get anything different.


 

Fix_that_Glitch

Notable
Mar 31, 2019
1,425
112
940
32
So Right off I see you don't have anistropic or antiailising, set those to use application setting. Maximum pre rendered frames set to 1. Have you set up the gsync in your Nvidia control panel, under display-set up Gsync? When playing your games, enable task manager, when the lag starts look at the task manager and see if something is slowing your games down and using memory, cpu, running in the background etc. If the game settings use laptop power saving, don't use it.
 
Aug 8, 2019
8
0
10
0
So Right off I see you don't have anistropic or antiailising, set those to use application setting. Maximum pre rendered frames set to 1. Have you set up the gsync in your Nvidia control panel, under display-set up Gsync? When playing your games, enable task manager, when the lag starts look at the task manager and see if something is slowing your games down and using memory, cpu, running in the background etc. If the game settings use laptop power saving, don't use it.
I messed with multiple settings including settings those anistropic and antialiasing to application settings and/or off, I also tried with maximum pre-rendered frames and virtual pre-rendered frames set to 1. I have my GSYNC setup in "Set up G-SYNC" in nvidia control panel for fullscreen.

Regarding the task manager thing, yes I've tried keeping it open and stuff, but I didn't manage to catch anything specific like that...
 
Aug 8, 2019
8
0
10
0
I've the refresh rate set to 120 as it is the highest available, also I've ran the test for 1 minute and it said that my PC can handle runtime audio without dropouts.
 

Fix_that_Glitch

Notable
Mar 31, 2019
1,425
112
940
32
Ok so the tool is meant to run in the background while you play your game. After playing your game then check the results to see if there is any spikes in latency when playing the game. Then you can see what files are acting up hopefully.
 
Aug 8, 2019
8
0
10
0
So see if your audio drivers need updating. What bios version are you running? Also if you go to this page it will scan your laptop and see if you need any new files. https://support.hp.com/id-en/drivers/selfservice/omen-by-hp-15-ce000-laptop-pc/15551437
I had updated my BIOS to the latest available one from HP, also I just re-scanned again now on the site and downloading all the available drivers that it suggested to me after detecting my laptop model and stuff.

I'll report back if something changes, however I'm not sure this will help.
 
Aug 8, 2019
8
0
10
0
One last thought, even though you have windows power management set to high performance, go in to bios and disable any power saving settings.
Everything is set to high performance on power modes as well as Nvidia control panel, don't seem to be solving, worth mentioning that I played GTA V and it runs 60fps smooth no problem, I also play Grand Theft Auto: San Andreas multiplayer (MTA:SA) and its butter smooth as well, however an older game like GTA Vice city and stutters like this one...

I seriously have no idea what the hell is going on.
 

ASK THE COMMUNITY

TRENDING THREADS